Avatar

a planned features for mlf 2.4, eine Bitte an @Milo (Project organisation)

by Micha ⌂, Monday, October 10, 2016, 15:55 (2695 days ago) @ Auge

Hi,

Daran muss ich halt nur denken.

Richtig, sonst sieht es schon mal blöd aus. Da ich so etwas von Anfang an geahnt hatte, habe ich vorsorglich bei XAMPP keine Passwörter vergeben. In meinem Live-Foren nutze ich diese db_settings-Datei gar nicht sondern eine Datei außerhalb vom Dokumentenroot.

Mit dem Merge zu 2.4 werde ich meine unglückliche Datenhaltung dann mal versuchen umzuorganisieren. Auch bin ich gespannt, wie man Konflikte dann auflöst. Da hatte ich heute den ersten Fall, als ich in den Master in den Bookmark mergen wollte. Mit GitHub-Desktop war ich dann schnell am Ende, da u.a. die index.php einen Konflikt hatte. Ich habe in der Datei dann die <<< >>> Einträge gesichtet und angepasst und mit git add <file> dann auf der Konsole gewerkelt. Das hätte ich mir eleganter vorgestellt...

Ja, dass stimmt aber im Moment sind bei PHP7 noch nicht einmal die mysqli_* Funktionnen dabei, sodass ich nur unter PHP5.6 live testen kann.


Ach herrje!

Und das ist noch untertrieben, wie ich finde.

Nun ja, wenn ich bei den Betaversionen daran gedacht hätte, diese in den Settings explizit als Betaversionen zu bezeichnen, könnte der geneigte Admin im Updateskript auch zwischen den Versionen unterscheiden. Mea Culpa!

Ja, ich hatte die Änderungen von beta 1 auf beta 2 händisch gemacht und es deswegen nicht bemerkt. Wer von einer der beiden Beta-Versionen auf die finale Version will, bekommt jetzt die Meldung:

Error in line 358: This update file doesn't work with the current version.

Man kann das natürlich mit Mut zum Coden als Admin auch selbst anpassen. In den Arrays und Vergleichen mit allen vorhergehenden Versionen müssen entsprechende Einträge ergänzt und dann der Versionsstring in den Einstellungen angepasst werden.

Soviel Mut sollten wir nicht voraussetzen und zukünftig die Versionen 2.3.7.1, 2.3.7.b1 oder so benennen.

Viele Grüße
Micha

--
applied-geodesy.org - OpenSource Least-Squares Adjustment Software for Geodetic Sciences

locked
55546 views

Complete thread:

 RSS Feed of thread