von 2.3.5 zur aktuellen.... (Bugs)

by Andreas Schneider, Thursday, April 06, 2023, 20:28 (472 days ago) @ Andreas Schneider

Hi,

habe heute einen neuen Versuch gestartet.
Beginnend mit der 2.3.5 bin ich auf 2.3.7 gegangen.

Die Empfehlung auch in der Datenbank die Foren-Adresse anzupassen, berücksichtigt.
Die 2.3.7 lief auch fehlerfrei, keiner der von mir genannten Fehler sind aufgetreten.

Vor dem nächsten Schritt:
theme ist default
templates_c Dateien gelöscht
Backup von Dateien der 2.3.7 und der DB
PHP war aber noch auf 5.6

Der Schritt zur 2.4.24 ist dann allerdings gescheitert.
Verschiedene Fehler, aber der wohl wichtigste: es ist https scheinbar zwingend vorgeschrieben.

Firefox meldet:
Beim Verbinden mit xxx-forum.de trat ein Fehler auf. Die Gegenstelle meldet, dass sie auf einen internen Fehler gestoßen ist.

Fehlercode: SSL_ERROR_INTERNAL_ERROR_ALERT
Die Website kann nicht angezeigt werden, da die Authentizität der erhaltenen Daten nicht verifiziert werden konnte.


Da ich die hierfür genutzte Domäne noch nicht auf https umgestellt hatte, komm ich hier nicht weiter ohne erstmal Geld an Ionos zu zahlen.

Mit Chromium wird das Forum zwar angezeigt, aber sowohl "antworten" als auch "neues Thema" springen um auf "xxx-forum.de/index.php?mode=login&action=tou" (kein Schreibfehler, exakt das).
"der Server hat eine falsche Anwort geliefert".
Sichtbar ist nur ein ausgegrautes Feld und 2 kleine Pseudobuttons drunter.

Als Fehlermeldung im Log:

06-Apr-2023 21:02:03 Europe/London] PHP Fatal error: Uncaught Error: Call to undefined function get_magic_quotes_gpc() in xxx/htdocs/forum_php8/includes/main.inc.php:8
Stack trace:
#0 xxx/htdocs/forum_php8/index.php(35): include()
#1 {main}
thrown in x/htdocs/forum_php8/includes/main.inc.php on line 8
[06-Apr-2023 21:02:12 Europe/London] PHP Fatal error: Uncaught Error: Call to undefined function get_magic_quotes_gpc() in xxx/htdocs/forum_php8/includes/main.inc.php:8
Stack trace:
#0 xx/htdocs/forum_php8/index.php(35): include()
#1 {main}
thrown in xxx/htdocs/forum_php8/includes/main.inc.php on line 8

Auch mit frisch gelöschtem templates_c Verzeichnis, keine Änderung.
Kopieren vom kompletten Dateibaum aus dem Archiv 2.4.24 - keine Änderung.

Würde es was bringen, vor dem Update von 2.4.24 auf PHP7.3 zu gehen?
Den Versuch kann ich ja noch machen.

Gruß
Andi


Complete thread:

 RSS Feed of thread