Avatar

von 2.3.5 zur aktuellen.... (Bugs)

by Auge ⌂, Sunday, April 09, 2023, 19:34 (406 days ago) @ Micha

Hallo

Hmm, ich weiß ja nicht, welchen Commit-Stand du da verlinkt hast,


Den aktuellen, welchen sonst. ;-)

Aber klar, ich habe jetzt nicht geschaut, wann welche Modifikation durchgeführt wurde. Insofern kann ich bestimmte Äußerungen auch nicht direkt reproduzieren. Auf meiner Seite versuche ich das Forum aktuell zu halten.

Im Moment plädiere ich daher, mal das Update durchzuziehen. Mir scheint, dass dieses Problem bereits gelöst wurde.

So sollte er es auch tun. Vorsichtshalber sollte Andreas aber ein Backup des gegenwärtigen Datenbankstands erzeugen, der die Datenbankstruktur der Version 2.4.24 widerspiegelt. Dann muss er, falls irgendetwas schief läuft, nicht wider am Ausgangspunkt beginnen. Und er muss prüfen, ob sich mehrere Accounts finden, die die selbe E-Mail-Adresse benutzen. Weil dann das Update unweigerlich schief gehen würde.

Das lässt sich in einem Datenbanktool wie der MySQL-Workbench oder phpMyAdmin mit dem folgenden Query prüfen. Die Tabellennamen sind bei Bedarf anzupassen.

SELECT
  `user_id`,
  `user_name`,
  `user_email`
FROM `mlf2_userdata`
WHERE `user_email` IN(
  SELECT
    `user_email`
  FROM `mlf2_userdata`
  GROUP BY `user_email`
  HAVING COUNT(`user_email`) > 1)
ORDER BY `user_email` ASC, `user_name` ASC

Da ich in dem Forum auf meiner Seite immer noch die Version 2.4.24 einsetze, habe ich mal danach gesucht. Stellt sich heraus, ich weiß nicht, wie ich ein Posting so zum löschen "vorschlage", dass ich eine Seite mit dem Template posting_delete.inc.tpl zu sehen bekomme.


In der aktuellen Version kommt es, wenn man sich im Posting befindet und auf löschen klickt - würde ich sagen. Das konnte ich zumindest in Deinem Forum gerade so nachvollziehen. Hierzu musst Du das Löschen in einem neuen Tab vornehmen, sodass das JS-Alter nicht erscheint (klick mit der mittleren Maustaste).

Ahh, das geht tatsächlich nur mit der mittleren Maustaste oder über das Kontextmenü. Wenn ich stattdessen die Kombination [STRG]+[Linksklick] benutze, die ebenfalls einen neuen Tab öffnen sollte, wird mir, wie beim einfachen Linksklick, der JS-Modaldialog angezeigt. Und ja, da gibt es in der Version 2.4.24 keinen CSRF-Token, egal ob in meinem Theme oder dem mitgelieferten.

Tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!


Complete thread:

 RSS Feed of thread