Avatar

Fatal error beim Update 2.3 --> 2.3.1 (German / Deutsch)

by Auge ⌂ @, Wednesday, July 11, 2018, 07:23 (5 days ago) @ Irene König

Hallo

Bitte berichte über deinen Umzug. Gerne auch über die Zwischenschritte, die du eventuell gehen musst(est).


mit etwas Verzögerung habe ich heute die Updates in Angriff genommen. Brav habe ich ab Version 2.2 jedes Update eingespielt. Das ging gut bis Version 2.3, nun gibt es ein Problem. Fehlermeldung:


Warning: include_once(/.../mlf2/modules/smarty/sysplugins/smarty_internal_templatebase.php): failed to open stream: No such file or directory in /www/htdocs/w00880a1/mlf2/modules/smarty/Smarty.class.php on line 96
...

Den Fehler sehe ich zum ersten Mal. Dein Link zu einem früheren Posting zeigt aber, dass du mit dem Problem nicht alleine bist/warst.

Das Script sucht nach der smarty_internal_templatebase.php, die Datei ist aber tatsächlich in dieser Version nicht vorhanden. Ich bin gerade etwas ratlos, da ich aktuell keinen Zugriff auf das Forum und die Updatefunktion habe. Hat jemand einen Tipp für mich?

Normalerweise würde ich empfehlen, die höchstmögliche Version (hier 2.3.5) drüberzubügeln. Da du aber so überhaupt keinen Zugriff auf dein Forum hast, musst du erst einmal ermitteln, wo der Updateprozess hingeführt hat.

Vermutlich hat der erste Schritt des Updates funktioniert, was bedeutet, dass alle Änderungen an und in der Datenbank erfolgt sind (einschließlich Anpassung der Versionsnummer). Das Updateskript der Version 2.3.4 vor Augen, kann ich aber sagen, dass es nach dem Sprung auf 2.3(.0) bis auf die Versionnummer in der Datenbank keine weiteren Änderungen gegeben hat. Du solltest also in phpMyAdmin in der Einstellungstabelle für den Schlüssel version den Wert "2.3.1" finden.

Das wiederum heißt, dass – abgesehen von der allfälligen Anpassung der Versionsnummer – von der Version 2.3(.0) bis einschließlich zur Version 2.3.4 ausschließlich Dateien aktualisiert werden. Du kannst dir also die Version 2.3.4 herunterladen, auspacken und die Dateien in das Verzeichnis des Forums hochladen, um das Forum wieder lauffähig zu bekommen. Danach müsstest du nur noch in die erweiterten Einstellungen gehen, um im Schlüssel version die dann aktuelle Versionnummer (2.3.4) nachzutragen.

Viel Erfolg!

Tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!


Complete thread:

 RSS Feed of thread

powered by my little forum