update auf 2.3.7?: eine Warnung und zwei Folgefehler (Technics)

by uli ⌂ @, bayern, Thursday, November 03, 2016, 22:34 (322 days ago) @ Auge
edited by uli, Thursday, November 03, 2016, 23:09

Hallo Auge,
hallo Micha,

Hintergrund von dem Ganzen (thema Newsletter lt. Hoster) ist die wunderschöne Funktion - Nachricht an den Admin bei 'neuem Eintrag'

diese Nachricht hat subject: Neuer Eintrag im Forum: (und Titel des Eintrags)

Ich vermute durch das immer gleiche subject erkennt der Hoster bzw. seine Technik das als NL. Wie oft hab ich denen die Situation schon beschrieben, dass das keine NL ist, sondern nur eine Mail; die gehen da gar nicht drauf ein, schicken immer nur den Hinweis auf SMTP. Wir hatten uns hier auch schon mal drüber ausgetauscht: mail() to PHPMailer (candleman)

(ich hatte allerdings jetzt nach der letzten Mail vom Hoster echt schiss, dass er mir den ganzen Auftrag (mit mehreren Projekten) fristlos kündigt, wenn sich diese "?Newsletterversendung?" fortsetzt. (so gaaaaanz nebenbei hatten der H diese Möglichkeit angedroht!)

So hab ich erstmal die "Nachricht an den admin bei neuem Eintrag" ausgeschaltet.

Dann den Versuch Update von 2.3.4 auf die aktuellste 2.3.7
Nachdem die als 'update_2.x-2.3.' bezeichnet war, erwartete ich kein Problem. Die Anleitung das in 'kleinen Schritten' zu machen, hab ich jetzt erst in eurem Link gelesen.

Das Forum läuft trotz der Warnmeldungen (puuh) aktuelle Version: 2.3.4(lt. admin/update)
Offensichtlich hat 'update' beendet wg. dieser Warnungen

Kannst du hier bitt mal den ganzen IF-Block um die Zeile 888 deiner update_2.x-2.3.php herum posten, damit wir sehen können, welcher Code an dieser Stelle ausgeführt werden soll?

der rund um 888 if Block

{
        $update['errors'][] = 'Database error in line '.__LINE__.': ' . mysqli_error($connid);
       }

Ich werd das jetzt mal Schritt für Schritt in kleinen Stufen machen, dann wirds schon.

Gruss und Dank

uli

Nachtrag:
update v 2.3.4 auf 2.3.5 hat geklappt.

bei update'versuch' von 2.3.5 auf 2.3.6 (mit vorherigem upload der entsprechenden Update-dateien) kommt folgende Meldung:

Error in line 297: This update file doesn't work with the current version.
  $update['errors'][] = 'Error in line '.__LINE__.': This update file doesn\'t work with the current version.';


Complete thread:

 RSS Feed of thread

powered by my little forum