Avatar

update auf 2.3.7?: eine Warnung und zwei Folgefehler (Technics)

by Auge ⌂ @, Wednesday, November 02, 2016, 12:17 (324 days ago) @ uli
edited by Auge, Wednesday, November 02, 2016, 12:33

Hallo

Lt. meinem Hoster hat die forum/includes/functions.inc.php (vom Aug 21 13:11) Newsletter versendet und damit den Server beeinträchtigt.

Ich kenne den Code nicht bis in den letzten Winkel selten verwendeter Funktionen, aber wenn Milo sagt, dass es keine Newsletterfunktion gibt, vertraue ich ihm. Er betreibt seit mehreren Jahren ein MLF2-basiertes Forum und ist auch schon lange an der Entwicklung beteiligt.

Allerdings kann MLF2 grundsätzlich Emails versenden. Wenn nicht noch eine uns unbekannte Sicherheitslücke klaffen sollte, wird eine Email aber nur an jeweils einen Adressaten gesendet und ein erneuter Versand einer weiteren Email für einen kurzen Zeitraum unterbunden.

Hast du eventuell weitere Infos von deinem Hoster erhalten, die du uns anbieten kannst?

Nach Recherche bei mlf hab ich festgestellt dass update von 2.3.4 empfohlen wird.
Das wollte ich jetzt nach Anleitung machen und bekommen unten stehende Warnungen.

Warning: mysqli_error() expects parameter 1 to be mysqli, resource given in /***/forum/update/update_2.x-2.3.php on line 888

Kannst du hier bitt mal den ganzen IF-Block um die Zeile 888 deiner update_2.x-2.3.php herum posten, damit wir sehen können, welcher Code an dieser Stelle ausgeführt werden soll?

Warning: Cannot modify header information …

Warning: Cannot modify header information …

Dabei handelt es sich um Folgefehler, die durch die erste Fehlermeldung erzeugt werden. Die Ursache dieser ersten Meldung gilt es zu beheben.

Was ist zu tun?

Beantworte bitte unsere Fragen. Wir kriegen das zusammen schon hin.

Tschö, Auge

--
further development of mlf1


Complete thread:

 RSS Feed of thread

powered by my little forum