My forum (v2.0) is getting very slow, any suggestion? (General)

by Steven @, Tuesday, September 01, 2020, 14:50 (57 days ago)

Hi Expert,

My forum is getting slower and slower. It could be cache problem. Anyone knows how to improve it. I don't know if new version resolve it.

Thank you,

Steven

My forum (v2.0) is getting very slow, any suggestion?

by shian, Wednesday, September 02, 2020, 13:47 (56 days ago) @ Steven

Hi Expert,

My forum is getting slower and slower. It could be cache problem. Anyone knows how to improve it. I don't know if new version resolve it.

I'm not an expert for anything.

  • 1. It could be a server problem. Maybe the server experience overload. Try to enter the forum in the middle of the night and see... if it's faster then the overload is on specific hours. (You can ask the server's admin).

  • 2. Disable options that require a lot of CPU (some of the options/advanced options, like "how many users..." etc are not really necessary; disabling them will free CPU time and your forum will load faster).

  • 3. If you made manual changes to the theme or anything else: shrink your file size by moving any HTML code to CSS, and also try to shrink the CSS file. Small theme will load much faster.

  • 4. If your forum loads lots of images... Well, that's great yet images require more CPU time, so consider to disable avatars and uploading images.

  • 5. Erasing & Reinstalling the forum (the same version) can solve some metaphysics problems which are not obvious. Recommended.

  • 6. Very long threads can slow things - try to split very long threads into few smaller threads, it will save CPU time.

  • 7. In your server's control panel disable "hot linking" - Maybe someone is downloading large files/images directly from your forum/site, using another site?

  • 8. Make sure that the size of images is reasonable - Large images (50K +) will become a bottleneck soon or later.

  • 9. Many servers are naturally getting slower as time goes by, when they serve more and more users, and do not upgrade their hardware/software - What about your server? This could certainly be a problem. (The server's admin may or may not tell you the truth...). Time to change a server?

  • 10. You did not mention how big is your forum, and how many users are using it. This is also a factor. If you are on a low price account, consider to move to better and faster deal.

  • 11. Try to analyze in which hours your forum is slow - it can help to solve the problem.

  • 12. If you also have a website, not only a forum on the same server then the total CPU time and bandwidth is common to the website as a whole. Make sure that other areas of your website are not taking all the CPU/bandwidth.

  • 13. Try to use the forum in https:// (if supported) and http:// - See if one of the protocols is faster. There may be a problem with the server.

  • 14. Small, Compact, Simple, Modular website runs much faster. Get rid of large scripts, large images, etc. Or again, change server or change deal to a faster one.

  • 15. If your website is modest, it is probably server fault. (could be even a malware in the server). - the server's admin can analyze your site's performances much better then you. Ask them.

  • 16. Try to use a different PHP version - computers are half physics and half metaphysics.

  • 17. Last: when everything goes wrong, you need to eliminate the things that go right, i.e. Install everything from the beginning, step by step. Check the speed on each step. See when things are getting slow... there is your problem.

  • 18. BTW - Maybe the problem is your computer! - then it's time to FORMAT your computer! And install Linux Mint (Linux Mint works fast...). Maybe your PC has lots of malwares...
Avatar

My forum (v2.0) is getting very slow, any suggestion?

by Auge ⌂ @, Wednesday, September 02, 2020, 14:23 (56 days ago) @ Steven

Hello

My forum is getting slower and slower. It could be cache problem. Anyone knows how to improve it. I don't know if new version resolve it.

Do you really run an installation of MLF in version 2.0?

As Shian said, there are many possible causes. Your server/the server with your webspace could have problems. Your forum database could be so large, that it impacts the performance of the forum software.

How many users are registered in your forum? How many entries and threads does your forum contain? What's the versions of PHP and MySQL on your server/in your webspace?

Beside from these questions, it is recommended to update your forum after a backup of the forum database. There are many fixes for security issues, for usability and performance problems, new features and so on. Depending of your starting point (Which version are you running?) you should be able run an update to version 2.3.5. After the update to version 2.3.5 you can run a second update from that version to version 2.4.21.

Tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!

RSS Feed of thread

powered by my little forum