Avatar

Thanks Auge. This is great news. (General)

by Auge ⌂, Saturday, March 25, 2023, 11:54 (386 days ago) @ Joe I

Hello

2) Port existing site and DB over to new instance. Update config/db_settings.php to reflect new DB settings.
2) Upgrade to 2.3.5.
3) Upgrade to 2.4.24.
4) Switch PHP version to 7.4.

Until here: nothing more than yes.

5) I know that we have at least a few duplicate email addresses, so I will clean up the DB before proceeding.

Yes, that is definitively necessary. I recommend to create a second backup of the current state after the check for doublettes for the case of a failing upgrade in the furter process steps.

6) Upgrade to 20220803.1 (2.5.4).

Yes.

7) Switch PhP version to 8.0 / 8.1.

Yes.

All necessary releases can be found at: https://github.com/My-Little-Forum/mylittleforum/releases

Our current version of MySQL is 5.6.51. The new instance MySQL version is 10.3.38.

MySQL 10.3.38 sounds like MariaDB. That has nothing to do with the PHP version and it should not be a problem.

My understanding is that both versions should work through the upgrade process, but I'll perform the upgrade on the newer, 10.3.38, instance.
If I run into any issues with the last upgrade, I'll take another look at the "Problems with the upgrade procedure from 2.4.x to 2.5" thread.

I recommend to ask here in your thread for help in a first step.

I've had a heck of a time exporting the data from the existing instance / DB, as either the script or DB is timing out before the export is complete. The entries table has 500,000 records and only 300,000 records could be exported before the timeout. I've got a piecemeal solution we're going to attempt today that should work.

Wow, 500,000 entries? That's a lot.

My one question at the moment: I thought I read on the forum that there was a problem with new DB tables that wasn't fixed until the upgrade script in 2.3.7 (and not 2.3.5).

There's nothing I am aware of. I inspected the update script for 2.4-versions [1], that starts with version 2.3.5 RC for an indicator for problems in the late 2.3-versions but I can't see one. Only a inconspicuous change in the settings table and a redefinition of one column in the userdata table.

Is this anything I need to worry about, or will that simply get fixed with the upgrade FROM 2.3.5 to 2.4.24?

I se no need to be afraid of the upgrade process to version 2.4.24. There are a plenty of people who upgraded to version 2.4.24 without any reports about serious problems.

Tschö, Auge

[1]: the location of the upgrade procedures from 2.3.5 to 2.3.7 in the upgrade script of version 2.3.7 and the same location in the upgrade script to version 2.4.24

--
Trenne niemals Müll, denn er hat nur eine Silbe!


Complete thread:

 RSS Feed of thread