Using mysqldump file on fresh install (General)

by dan, Monday, August 02, 2021, 04:08 (58 days ago) @ Auge

If you say, your installation is nearly 10 years old, what version of MLF are you running? If you didn't update your installation to a recent version over the years, the table structure of your installation is not compatible with the structure of the current version (2.4.24). There was made many changes at the database structure.

Thank you for your response. I am running 2.4 and have been careful to keep it updated over the years.

Afterwards you should be able to create a fresh installation of MLF and to restore the database backup in your new installation.

This is what I tried, fresh install, new database, import mysqldump file into new database, but it doesn't work. When I try to open the new installation, I just get a blank page. I rarely (as in almost never) restore databases using phpmyadmin, so I may be doing something wrong on that step. But the fact that some of my admin functions are not working properly on my current installation leads me to think that there may be something more messed up.

Beside your problem it would be interesting to know the cause of your initial problem (not being able to alter a user profile). Older versions run on a not well optimised database setup with absent indexes for several columns in several of the tables.

The forum runs great as a user. When I try to add a user, I get this error:

Error!

Array

Same error if I try to edit a user.

Thanks again!


Complete thread:

 RSS Feed of thread

powered by my little forum