Avatar

Error on update (Technics)

by Solis ⌂ @, Urumqi, Xinjiang, China 中国新疆乌鲁木齐, Sunday, February 19, 2017, 14:59 (99 days ago)
edited by Auge, Monday, February 20, 2017, 12:28

Thanks for the new version!

Now I use the version 2.3.7. I want to update to version 2.4. I upload the files update.sql and update_2.3.5-2.4.php to the folder update.

[image]

When I update the forum, the system said:

Error in line 137: Missing the file config/VERSION.

[image]

Avatar

Error on update

by Milo ⌂, Sunday, February 19, 2017, 18:22 (99 days ago) @ Solis

Hi,

When I update the forum, the system said:
Error in line 137: Missing the file config/VERSION.

The update process in itself requires an upload of both files, the update/update_2.3.5_2.4.php as well as the config/VERSION.

/Micha

--
Surveyor-Software: Geodetic Network Adjustment & Deformation-Analysis and Transformation

Tags:
Update, 2.4, VERSION-file

Avatar

Error on update

by Auge ⌂ @, Monday, February 20, 2017, 08:51 (98 days ago) @ Milo

Hello Milo and Solis

When I update the forum, the system said:
Error in line 137: Missing the file config/VERSION.


The update process in itself requires an upload of both files, the update/update_2.3.5_2.4.php as well as the config/VERSION.

The need of the new requirement seems to be unclear. I will adapt the installation and update instructions and change the error message to be more descriptive.

Tschö, Auge

--
further development of mlf1

Tags:
update, 2.4, VERSION-file

Avatar

Error on update

by Auge ⌂ @, Monday, February 20, 2017, 09:22 (98 days ago) @ Auge

Hello Auge

I'll answer myself

I will adapt the installation and update instructions

No need to change the installation instructions because it promts to upload the whole folder (including the file config/VERSION. There's also no need to change the update instructions because the necessarity to upload config/VERSION is always stated there in step 1.

- above version 2.3.7: Load the files update/update_2.3.5_2.4.php, config/VERSION and update/update.sql up to the server.

and change the error message to be more descriptive.

This task remains.

Tschö, Auge

--
further development of mlf1

Avatar

Error on update

by Solis ⌂ @, Urumqi, Xinjiang, China 中国新疆乌鲁木齐, Thursday, February 23, 2017, 12:41 (95 days ago) @ Auge

Thanks for your help. Auge and Mile are so nice!

Maybe you can change the installation to:

Missing the file config/VERSION. Please upload it at first!

--
I speak Chinese & Esperanto.
我说汉语和世界语。
Mi parolas ĉine kaj Esperante.
-----------------------------
http://reto.cn
my forum using MLF
http://reto.cn/forum

Avatar

Error on update

by Auge ⌂ @, Thursday, February 23, 2017, 13:09 (95 days ago) @ Solis

Hello

Maybe you can change the installation to:

Missing the file config/VERSION. Please upload it at first!

Ahem and ahem. It's part of version 2.4.1.

Tschö, Auge

PS: „Ahem“ is a german phoneme for „to harrumph“ or „to hem“.

--
further development of mlf1

Avatar

Error on update, proposal for solution

by Auge ⌂ @, Monday, February 20, 2017, 12:27 (98 days ago) @ Solis
edited by Auge, Monday, February 20, 2017, 12:41

Hello

When I update the forum, the system said:

Error in line 137: Missing the file config/VERSION.

Like Milo said, the version 2.4 needs this file to process the update. Load it up and the update will proceed.

The message tells you the same in a less descriptive manner. Thatswhy I want to make the error message tellig you more. Would "Missing the file config/VERSION. Load it up from your script package before proceeding." be clearer?

[edit]replaced "continuing" with "proceeding"[/edit]

Tschö, Auge

--
further development of mlf1

RSS Feed of thread
powered by my little forum