Set Thread Mode as Default (Design/Themes)

by Wendell ⌂ @, Salem, OR, USA, Tuesday, August 03, 2010, 17:20 (3361 days ago)
edited by Wendell, Tuesday, August 03, 2010, 17:34

I have searched this forum looking for the answer to this question and it seems that the answer is a bit outdated. I am using 2.2.6.

I did manage to find some areas in the templates that I could change by simply adding "mode=thread" to the URL. However, there are still a couple of places where it is not in thread mode:

  • After submitting a new topic, the user is taken to the non-thread-mode version of the thread.
  • When using the "msg" BBCode in postings, the resulting posting link doesn't not contain "mode=thread" in the URL.

I have not been able to locate where to change these! I would actually prefer to somehow not use the "mode=thread" in the URL (like maybe have an admin setting to default all threads to thread mode), but for now, if anyone can help find these last two code locations, I would appreciate it very much! :-)

Set Thread Mode as Default

by Riba ⌂ @, Thursday, August 05, 2010, 23:48 (3359 days ago) @ Wendell

Hey Wendell,

What I found out is that once I set the view to threaded it sticks...and I checked the code which confirms this as this setting is stored in a cookie. AT least that's what I found out from my (limited) testing.

Set Thread Mode as Default

by Wendell ⌂ @, Salem, OR, USA, Thursday, August 05, 2010, 23:54 (3359 days ago) @ Riba

Sorry, what I meant was so that thread mode is forced upon all users. :)

Set Thread Mode as Default

by Riba ⌂ @, Thursday, August 05, 2010, 23:55 (3359 days ago) @ Wendell

I see... I did some digging through the javascript code which seems to control this behavior, and had limited success. I may take another go, but I am not an expert in javascript so it is a pain. :)

RSS Feed of thread
powered by my little forum