Fix for "post reply" link missing in IE6 (Design/Themes)

by Wendell ⌂ @, Salem, OR, USA, Sunday, July 11, 2010, 19:56 (3332 days ago)

In IE6 (yeah, yeah, I know), the "post reply" link in all of the posts do not show up. The link is there (you can hover and click in the proper location), you just can't see the text.

To fix this, change the following CSS in style.min.css:
.thread-posting{position:relative;border-left:10px solid #d2ddea;border-right:1px solid #f0f0f0;border-top:1px solid #f0f0f0;border-bottom:1px solid #f0f0f0;margin:0 0 20px 0;padding:0;background:#fff;}

To:
.thread-posting{position:relative;border-left:10px solid #d2ddea;border-right:1px solid #f0f0f0;border-top:1px solid #f0f0f0;border-bottom:1px solid #f0f0f0;margin:0 0 20px 0;padding:0;background:inherit;}

Or, simply remove background:#fff; from .thread-posting in style.min.css completely.

This fix has no impact on how the forum is displayed in Firefox, so you don't need a special conditional to detect IE6 users or a separate CSS file. Since the main background is already white, setting the post box to a white background is redundant. If you changed the main background color from white to something else, well, you may have to get more creative.

I realize that IE6 is an old dog that needs to be put down. But it doesn't change the fact that many of us still have users with IE6. So, if you want to accommodate them, this is a handy fix. I hate IE6 as much as the next guy, but I do not want to alienate my users and many of them have no choice because the company they work for hasn't upgraded for a long time. Sad, but true.

IE6 no more

by davwat ⌂ @, Western Australia, Thursday, July 15, 2010, 05:23 (3328 days ago) @ Wendell

You may find the following web page of interest.

IE6 no more
http://www.ie6nomore.com/

RSS Feed of thread
powered by my little forum