HTTP Error 500 beim Erstellen neuer Beiträge (General)

by BlindFish1003, Tuesday, February 28, 2023, 10:14 (447 days ago)

Hallo,

seit dem Update auf 20220803.1 habe ich das Problem, dass Benutzer keine Beiträge mehr erstellen können und als Resultat nur einen HTTP Error 500 zurückbekommen. Der Admin hingegen kann weiterhin Beiträge erstellen.

Zugriffsrechte auf linuxbasierten Webservern sind leider nicht so mein Thema, aber vielleicht hat jemand eine Idee, wo ich suchen muss?

VG Markus

Avatar

HTTP Error 500 beim Erstellen neuer Beiträge

by Auge ⌂, Tuesday, February 28, 2023, 14:16 (447 days ago) @ BlindFish1003

Hallo

seit dem Update auf 20220803.1 habe ich das Problem, dass Benutzer keine Beiträge mehr erstellen können und als Resultat nur einen HTTP Error 500 zurückbekommen. Der Admin hingegen kann weiterhin Beiträge erstellen.

Na super. Das hört sich ja nach gestochere und Herumgesuche an.

Zugriffsrechte auf linuxbasierten Webservern sind leider nicht so mein Thema, aber vielleicht hat jemand eine Idee, wo ich suchen muss?

Mit betriebssystem- und dateisystembezogenen Zugriffsrechten dürfte das nichts zu tun haben. Die Skripte werden immer vom selben Systembenutzer ausgeführt, egal, ob das Skript von einem nicht registrierter Besucher oder einem eingeloggter Benutzer jeglichen Rangs aufgerufen wird. Allerdings besteht, deiner Beobachtung nach, offensichtlich ein Unterschied bei der Verarbeitung eines neu anzulegenden Postings zwischen Admins und Mods einerseits sowie registrierten Benutzern (und nicht registrierten Besuchern?) andererseits.

Nun ist die Forumssoftware MLF beileibe nicht soweit verbreitet wie einige der allfälligen BB-$irgendwas-Boards, aber dennoch wundert es mich, dass ein solcher Fehler ein halbes Jahr nach der Veröffentlichung der Version noch nicht von anderer Seite gemeldet wurde. Um das Fehlerbild weiter zu konkretisieren, habe ich noch ein paar Fragen und Bitten.

1. Welche PHP-Version ist im Einsatz?
2. Welche MySQL- oder MariaDB-Version ist im Einsatz?
3. Hast du eigene Anpassungen an einem der Skripte (in diesem Fall speziell der Datei includes/posting.inc.php) vorgenommen?
4. Hast du eigene Anpasusngen am Theme (hier speziell der Datei themes/default/subtemplates/posting.inc.tpl) vorgenommen?
5. Kannst du bitte testen oder testen lassen, ob der Fehler auch bei der Bearbeitung eines bereits vorhandenen Eintrags auftritt oder doch nur beim anlegen eines neuen Beitrags?

Danke im Voraus für die Informationen. Sie werden bei der Ursachensuche sehr behilflich sein.

Tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!

HTTP Error 500 beim Erstellen neuer Beiträge

by BlindFish1003, Tuesday, February 28, 2023, 15:00 (446 days ago) @ Auge

Hallo,

1. Welche PHP-Version ist im Einsatz?

PHP 8.1

2. Welche MySQL- oder MariaDB-Version ist im Einsatz?

MySQL 5.7.38

3. Hast du eigene Anpassungen an einem der Skripte (in diesem Fall speziell der Datei includes/posting.inc.php) vorgenommen?

Nein

4. Hast du eigene Anpasusngen am Theme (hier speziell der Datei themes/default/subtemplates/posting.inc.tpl) vorgenommen?

Nein

5. Kannst du bitte testen oder testen lassen, ob der Fehler auch bei der Bearbeitung eines bereits vorhandenen Eintrags auftritt oder doch nur beim anlegen eines neuen Beitrags?

Auch das Beantworten vorhandener Beiträge führt bei Benutzern im Rang User zu einer Fehlermeldung.

Danke im Voraus für die Informationen. Sie werden bei der Ursachensuche sehr behilflich sein.

Danke vorab für die Bereitschaft zur Unterstützung.

VG Markus

Avatar

HTTP Error 500 beim Erstellen neuer Beiträge

by Auge ⌂, Thursday, March 02, 2023, 08:13 (445 days ago) @ BlindFish1003

Hallo

5. Kannst du bitte testen oder testen lassen, ob der Fehler auch bei der Bearbeitung eines bereits vorhandenen Eintrags auftritt oder doch nur beim anlegen eines neuen Beitrags?


Auch das Beantworten vorhandener Beiträge führt bei Benutzern im Rang User zu einer Fehlermeldung.

Dürfen in deinem Forum unregistrierte Besucher posten und wenn ja, sind diese auch von dem 500-er betroffen?

Danke vorab für die Bereitschaft zur Unterstützung.

Danke für die Infos. Die MySQL-Version ist definitiv unverdächtig. Eventuell ist für die Suche deine PHP-Version (8.1) interessant.

Tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!

HTTP Error 500 beim Erstellen neuer Beiträge

by BlindFish1003, Friday, March 03, 2023, 12:00 (444 days ago) @ Auge

Hallo Auge,

Dürfen in deinem Forum unregistrierte Besucher posten und wenn ja, sind diese auch von dem 500-er betroffen?

Nein, nur registrierte User dürfen Posts im Forum erstellen.

Danke für die Infos. Die MySQL-Version ist definitiv unverdächtig. Eventuell ist für die Suche deine PHP-Version (8.1) interessant.

Ein Wechsel auf PHP 8, was die älteste unterstützte Version bei unserem Provider ist, hat kein verändertes Verhalten gezeigt. Auch damit kommt es beim Erstellen neuer Beiträge zu einer Fehlermeldung.

Avatar

Bitte nicht beachten: HTTP Error 500 ...

by Auge ⌂, Friday, March 03, 2023, 15:14 (443 days ago) @ BlindFish1003

Hallo

[edit]
Achtung: Ich bitte darum, diesem Beitrag im Kontext deiner Fragestellung nicht zu beachten. Dass die von mir benannte Stelle vermutlich den Unterschied macht, ist vermutlich richtig, aber es geht ja nicht darum, dass die Einträge verschwinden (wegen Spam-Verdacht), sondern dass der Server den Status 500 zurück gibt.

Die Beantwortung der Fragen nach den aktivierten Spam-Schutz-Funktionen könnte aber bei der weiteren Eingrenzung der Ursache behilflich sein.

Ich lasse daher das Posting da. Zudem mag es auch in anderen Fällen hilfreich sein.
[/edit]

Danke für die Infos. Die MySQL-Version ist definitiv unverdächtig. Eventuell ist für die Suche deine PHP-Version (8.1) interessant.


Ein Wechsel auf PHP 8, was die älteste unterstützte Version bei unserem Provider ist, hat kein verändertes Verhalten gezeigt. Auch damit kommt es beim Erstellen neuer Beiträge zu einer Fehlermeldung.

Der einzige Bereich, in dem zwischen Administratoren und Moderatoren auf der einen Seite sowie registrierten Benutzern und nicht registrierten Besuchern auf der anderen Seite unterschieden wird, ist die Spam-Prüfung ab Zeile 900 der posting.inc.php. Sowohl bei der Prüfung mit Hilfe von Akismet (beginnend mit Zeile 920) als auch bei der Benutzung der Bayes-basierten Wahrscheinlichkeitsberechnung (relevanter Code beginnt mit Zeile 979) werden Postings vopn Administratoren und Moderatoren von vornherein anders behandelt als jene von "einfachen" Benutzern und Besuchern.

Wenn Postings als Spam eingeordnet werden, werden sie, abhängig von den konkreten Einstellungen, entweder sofort gelöscht oder zumindest ausgeblendet. Daher möchte ich dir folgende Fragen stellen.

Siehst du in der Sidebar den Link zum anzeigen von Spam-Postings?

[image]

Wenn ja, dann klicke auf den Link, öffne jedes der nun angezeigten Postings und klassifiziere es jeweils als Ham (kein Spam) oder als Spam.

[image]

Hast du in deinem Forum für Einträge die Prüfung mit dem Bayes-Filter (B8) eingeschaltet? (zu finden in Admin=>Spamschutz)

[image]

Hast du in deinem Forum für Einträge die Prüfung mit Akismet eingeschaltet (im Screenshot aus)? (zu finden in Admin=>Spamschutz)

[image]

Werden in deinem Forum als Spam klassifizierte Einträge vorläufig gespeichert (Häkchen gesetzt) oder werden sie sofort gelöscht (Häkchen nicht gesetzt)? (zu finden in Admin=>Spamschutz)

[image]

Wenn das nicht der Fall ist, schalte diese Funktion bitte ein und bitte den einen oder anderen deiner Benutzer, ein Posting zu schreiben. Ich vermute, dass du die ersten Postings erst einmal in der Liste der Spam-Postings finden und sie als Ham (Nicht-Spam) wirst klassifizieren müssen (siehe Frage 1).

Ich hoffe mal, dass ich mit meiner Vermutung richtig liege. Ansonsten geht die Suche nach der Ursache weiter.

[edit]Ach ja, was ich noch fragen wollte: Wenn deine Forumsbenutzer eine Fehlermeldung zu sehen bekommen, wie lautet die denn?[/edit]

Tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!

Bitte nicht beachten: HTTP Error 500 ...

by BlindFish1003, Saturday, March 04, 2023, 10:06 (443 days ago) @ Auge

Guten Morgen,

der Hinweis auf die Spamschutz-Einstellungen hat mich scheinbar auf die richtige Spur gebracht, denn das deaktivieren der Prüfung für angemeldete User hat jetzt als Workaround erst einmal geholfen. An die qualifizierte Fehlersuche anhand Deiner Infos werde ich mich wohl erst morgen machen können, in meiner Sidebar tauchen die Punke zum Spamschutz aber nicht auf, obwohl auf den ersten Blick alle Optionen in den Einstellungen aktiv waren.

Viele Grüße
Markus

Avatar

Bitte nicht beachten: HTTP Error 500 ...

by Auge ⌂, Monday, March 06, 2023, 08:40 (441 days ago) @ BlindFish1003

Hallo

der Hinweis auf die Spamschutz-Einstellungen hat mich scheinbar auf die richtige Spur gebracht, denn das deaktivieren der Prüfung für angemeldete User hat jetzt als Workaround erst einmal geholfen.

Zumindest das ist ein weiterer Hinweis für die Eingrenzung der Ursache. Danke dafür.

in meiner Sidebar tauchen die Punke zum Spamschutz aber nicht auf, obwohl auf den ersten Blick alle Optionen in den Einstellungen aktiv waren.

Naja, kann ja nicht. Unregistrierte Besucher können in deinem Forum nicht posten, also gibt es von dieser Seite keine als Spam vorqualifizierten Postings. Da die Postings von registrierten Benutzern in deinem Forum nicht gespeichert werden, wenn sie systemseitig vorqualifiziert werden (HTTP-Status 500), gibt es auch aus dieser Richtung keine Postings, die unter Spamverdacht stehen könnten.

Da es also gar keine Postings unter Spamverdacht geben kann, gibt es auch zu keinem Zeitpunkt einen Link zur Anzeige solcher Postings in der Sidebar.

Tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!

Avatar

Bitte nicht beachten: HTTP Error 500 ...

by Auge ⌂, Monday, March 06, 2023, 15:45 (440 days ago) @ BlindFish1003

Hallo

Ich habe da noch eine Frage.

der Hinweis auf die Spamschutz-Einstellungen hat mich scheinbar auf die richtige Spur gebracht, denn das deaktivieren der Prüfung für angemeldete User hat jetzt als Workaround erst einmal geholfen.

Welche Spamschutzmaßnahme ist bei dir für Forumseinträge aktiv? Ist es Akismet, Bad Behavior oder der Bayes-basierte Filter B8? [1] Diese Information würde das Suchfeld weiter einengen.

Tschö, Auge

[1]: Ok, das waren zwei Fragen.

--
Trenne niemals Müll, denn er hat nur eine Silbe!

Bitte nicht beachten: HTTP Error 500 ...

by BlindFish1003, Tuesday, March 07, 2023, 16:11 (439 days ago) @ Auge

Hallo,

Welche Spamschutzmaßnahme ist bei dir für Forumseinträge aktiv? Ist es Akismet, Bad Behavior oder der Bayes-basierte Filter B8? [1] Diese Information würde das Suchfeld weiter einengen.

Die derzeitige Konfiguration sieht so aus:
BB Eintragsformular prüfen
Stop Forum Spam ist aktiv.
Bad Hebaviour ist aktiv.
Akismet Eintragsformular prüfen ist aktiv.

Ich habe das Forum nicht selbst aufgesetzt und nur die technische Pflege übernommen. Da bisher alles funktioniert hat, habe ich mich darum nicht weiter gekümmert, möglicherweise ist da aber auch mehr aktiv, als notwendig wäre, ich müsste auch mal prüfen, ob der Key für Akismet noch passt.


Viele Grüße
Markus

Avatar

Bitte nicht beachten: HTTP Error 500 ...

by Auge ⌂, Thursday, March 09, 2023, 11:05 (438 days ago) @ BlindFish1003

Hallo

Welche Spamschutzmaßnahme ist bei dir für Forumseinträge aktiv? Ist es Akismet, Bad Behavior oder der Bayes-basierte Filter B8?


Die derzeitige Konfiguration sieht so aus:
BB Eintragsformular prüfen
Stop Forum Spam ist aktiv.
Bad Hebaviour ist aktiv.
Akismet Eintragsformular prüfen ist aktiv.

Ok, dröseln wir das mal auf.

Der bayes-basierte Filter (B8) ist bei dir zur Prüfung neuer Einträge aktiv und war es bis vor kurzem auch für Einträge von registrierten Benutzern.

Stop Forum Spam prüft lediglich E-Mail-Adressen und das auch nur im Registierungsprozess. Das hat also nichts mit einer Prüfung des Inhalt eines neuen Eintrag zu tun.

Bad Behavior können wir an dieser Stelle auch rauslassen. Der schaut nur die HTTP-Header und die IP an und wenn das nicht funktionieren würde, würde es das in jedem einzelnen Fall nicht tun.

Die Überprüfung von Einträgen mit Akismet ist bei dir ebenfalls aktiv und war es bis vor kurzem auch für registrierte Benutzer. Relevant ist die Prüfung von neuen Einträgen mit B8 und Akismet mit deinen jetzigen Einstellungen nicht mehr. Die Einträge von Administratoren und Moderatoren werden sowieso nicht geprüft, die von registrierten Benutzern werden zur Umgehung des Fehlers nun ebenfalls nicht mehr geprüft und nicht registrierte Besucher können in dem von dir betreuten Forum sowieso nicht posten. Die Prüfungen laufen aktuell für Einträge also nur leer mit.

Es bleiben also nachwievor als mögliche Verursacher des 500-ers die von mir schon anfangs verdächtigten Dienste Akismet und B8 übrig, da das die einzigen Stellen im Prüf- und Speicherprozess von Postings (ob neu oder bearbeitet) sind, wo zwischen Postings von registrierten Benutzern und von Mitgliedern des Forum-Teams unterschieden wird.

Da bisher alles funktioniert hat, habe ich mich darum nicht weiter gekümmert, möglicherweise ist da aber auch mehr aktiv, als notwendig wäre, ich müsste auch mal prüfen, ob der Key für Akismet noch passt.

Da ich diesen Fehler nicht nachvollziehen kann, bin ich auf deine Unterstützung angewiesen. Interessant wären Tests der Prüfung von Postings von registrierten Benutzern, jeweils einmal mit aktiviertem B8 (Bayes-Filter) und ohne Akismet und einmal nur mit Akismet aber ohne B8.

Wenn sich dabei dein Verdacht bezüglich des Keys für Akismet bestätigen sollte, muss ich nicht einem Geist im Code nachjagen. Ansonsten würde die Ursache zumindest weiter eingekreist.

Danke schon einmal im voraus und tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!

RSS Feed of thread