Probleme bei der Installation (German / Deutsch)

by Clemens @, Sunday, December 29, 2019, 21:16 (23 days ago)

Hallo,

ich hatte das Forum viele Jahre laufen, dann habe ich die Umstellung der php-Version bei meinem Anbieter verpaßt, das Forum ging nicht mehr.

Leider schaffe ich es nicht, das Forum neu zu installieren. Es schein nach zwar zunächst zu klappen, aber bei meinem Test (eigenen Beitrag schreiben und einmal selbst darauf antworten) stürzt das Forum ab:

Deprecated: The each() function is deprecated. This message will be suppressed on further calls in /kunden/154468_61184/forum/includes/functions.inc.php on line 2260

Warning: Cannot modify header information - headers already sent by (output started at /kunden/154468_61184/forum/includes/functions.inc.php:2260) in /kunden/154468_61184/forum/includes/posting.inc.php on line 1010

Wenn ich den Beitrag dann mit "F5" wiederhole, klappt es. ! ???

"154468" ist die Datenbank

PHP-Version = 7-72STABLE-STANDARD (Anbieter stellt zum 02.03.20 die Versionen 4, 5, 7.0, 7.1 ein)

MySQL Version = 5.6.19

Hat jemand einen Tip?

Viele Grüße

Clemens

Probleme bei der Installation

by Clemens @, Sunday, December 29, 2019, 21:20 (23 days ago) @ Clemens

Wenn ich an den Einstellungen etwas ändern möchte, kommt folgende Meldung


Deprecated: The each() function is deprecated. This message will be suppressed on further calls in /kunden/154468_61184/forum/includes/admin.inc.php on line 833

Warning: Cannot modify header information - headers already sent by (output started at /kunden/154468_61184/forum/includes/admin.inc.php:833) in /kunden/154468_61184/forum/includes/admin.inc.php on line 849

Avatar

Probleme bei der Installation

by Auge ⌂ @, Wednesday, January 01, 2020, 19:06 (20 days ago) @ Clemens

Hallo

Wenn du dich dazu in der Lage fühlst, kannst du deine 2.4.x-er Version (mutmaßlich 2.4.20?) selbst patchen, um die Meldung loszuwerden. Lies erst einmal die Meldung mit der Diskussion über die Lösung und schaue dir danach die konkrete Umsetzung an.

Die betroffenen Codestellen können sich in anderen Zeilen befinden, da die Änderungen auf dem Entwicklungsbranch (aktuell für 2.5) stattfanden, der Code im 2.4-er Branch aber anders geordnet sein kann. Suche mit deinem Editor am besten nach "each(", um die Stellen zu finden. Zur vollständing als geändert markierten Funktion my_quoted_printable_encode sei gesagt, dass für dich nur die Anderung von while(list(, $line) = each($lines)) nach foreach ($lines as $line) relevant ist (im Repo in Zeile 2521). Der Rest ist Umformatierung, um den Code an unseren neuen Codestyle anzupassen und erst einmal nicht notwendig.

Wenn ich an den Einstellungen etwas ändern möchte, kommt folgende Meldung

Deprecated: The each() function is deprecated. This message will be suppressed on further calls in /kunden/154468_61184/forum/includes/admin.inc.php on line 833

Warning: Cannot modify header information - headers already sent by (output started at /kunden/154468_61184/forum/includes/admin.inc.php:833) in /kunden/154468_61184/forum/includes/admin.inc.php on line 849

Tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!

Avatar

Probleme bei der Installation

by Micha ⌂, Monday, December 30, 2019, 11:28 (22 days ago) @ Clemens

Hi,

das Problem ist bereits gelöst in der 2.4.99.xxx Version. Du müsstest also auf diese Vorabversion zurückgreifen. Ich denke Auge will sein Feature noch fertigstellen, bevor es das offizielle 2.5 gibt.

/Micha

--
applied-geodesy.org - OpenSource Least-Squares Adjustment Software for Geodetic Sciences

Probleme bei der Installation

by Clemens @, Monday, December 30, 2019, 12:01 (22 days ago) @ Micha

Hallo Micha,

danke für die rasche Antwort, ich werde es ausprobieren.

Viele Grüße

Clemens

Avatar

Probleme bei der Installation

by Micha ⌂, Tuesday, December 31, 2019, 12:07 (21 days ago) @ Clemens

Hallo Clemens,

ich werde es ausprobieren.

Sehr gut. Ich nutze die Version auch schon bei mir - insbesondere um Erfahrungen mit B8 zu bekommen. Letzteres ist bei mir der einzige aktive SPAM-Filter und ich bin gegenwärtig sehr zufrieden.

Guten Rutsch
Micha

--
applied-geodesy.org - OpenSource Least-Squares Adjustment Software for Geodetic Sciences

Tags:
2.5, B8, SPAM, PHP7

Avatar

Probleme bei der Installation

by Alfie ⌂ @, Vienna, Austria, Wednesday, January 01, 2020, 09:15 (20 days ago) @ Micha

Hallo Micha,

Ich nutze die Version auch schon bei mir

Äh, wo?

--
Cheers,
Alfie (Helmut Schütz)
BEBA-Forum (v1.8β)

Avatar

Probleme bei der Installation

by Micha ⌂, Wednesday, January 01, 2020, 12:46 (20 days ago) @ Alfie

Hallo,

Ich nutze die Version auch schon bei mir


Äh, wo?

Das Protokoll fehlte, habe es korrigiert.

--
applied-geodesy.org - OpenSource Least-Squares Adjustment Software for Geodetic Sciences

RSS Feed of thread
powered by my little forum