Beitrag löschen nicht möglich (General)

by candleman ⌂, Wednesday, July 17, 2019, 17:56 (31 days ago)
edited by candleman, Wednesday, July 17, 2019, 18:22

Die Versionsnummer Ihrer Installation: 2.4.20
da ist ein Knoten drin:

Ich will als Admin einen Beitrag löschen.
Das lässt mlf nicht zu.
Und interessanterweise gibt es oben den Link: zurück zu "Beitrag von unbekannt".
Dabei stand über dem Beitrag ganz klar der Benutzername

Was ist zu tun ?
ausser den Beitrag über direkten Datenbankzugriff zu löschen ?

[image]

[edit]: Bild im Forum hochgeladen und von hier eingebunden; Auge

Avatar

Beitrag löschen nicht möglich

by Auge ⌂ @, Friday, July 19, 2019, 08:03 (29 days ago) @ candleman

Hallo

Ich will als Admin einen Beitrag löschen.
Das lässt mlf nicht zu.

Beiträge lassen sich auf verschiedenen Wegen löschen.

1. Threadliste (Hauptansicht), Klick auf den X-Button
2. Threadliste (Hauptansicht), Thread mit dem O-Button markieren und über den "markierte Threads löschen" … naja … löschen
3. Postingansicht, Klick auf den Löschen-Button des Postings

Auf welchem Weg hast du es versucht und bist gescheitert?

Und interessanterweise gibt es oben den Link: zurück zu "Beitrag von unbekannt".
Dabei stand über dem Beitrag ganz klar der Benutzername

Der Beitrag existierte nach der Aktion weiterhin oder wurde er im Hintergrund trotz der Fehlermeldung doch gelöscht?

[edit]: Ich habe hier einen älteren Beitrag aus dem Beitrag heraus löschen können. Auch hier ist die Version 2.4.20 im Einsatz. Grundsätzlich funktioniert es also.

Tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!

Beitrag löschen

by candleman ⌂, Friday, July 19, 2019, 23:48 (28 days ago) @ Auge
edited by candleman, Friday, July 19, 2019, 23:58

Hallo Auge, danke für die schnelle Rückmeldung.

1. Threadliste (Hauptansicht), Klick auf den X-Button
2. Threadliste (Hauptansicht), Thread mit dem O-Button markieren und über den "markierte Threads löschen" … naja … löschen
3. Postingansicht, Klick auf den Löschen-Button des Postings

Auf welchem Weg hast du es versucht und bist gescheitert?

= Erster Versuch 3. Postingansicht //nicht möglich mit dem oben beschriebenen Effekt
= Zweiter versuch 1. Threadliste Hauptansicht, Klick auf den x button
= an die 2. Möglichkeit dachte ich nicht und hatte das nicht probiert.

Und interessanterweise gibt es oben den Link: zurück zu "Beitrag von unbekannt".
Dabei stand über dem Beitrag ganz klar der Benutzername


Der Beitrag existierte nach der Aktion weiterhin oder wurde er im Hintergrund trotz der Fehlermeldung doch gelöscht?

Der Beitrag war immer noch da !

Nachtrag: mit Variante 2 hat es heute geklappt.

Nachtrag zum Nachtrag:

Gerade eben einen neuen Beitrag als Normaluser erstellt,
Löschen mit Variante 3 geht nicht, bekanntes Fehlerbild, auch mit den Hinweis "zurück zum Beitrag von unbekannt"

Fehlerbild wie im ersten Post.

Löschen mit Variante 1. geht nicht, gleiches Fehlerbild w.o.

Löschen mit Variante 2. "Eintrag markieren" und dann "markierte Einträge löschen", das geht.

Reproduzierbar, 5 Versuche nacheinander mit neuen Beiträgen als User und löschen als admin.

Ich bin irritiert, weiss jetzt aber zumindest eine funktionierende Lösung.
Bisher hatte ich immer Variante 3 benutzt. Seit welcher Version das nimmer geht, kann ich nicht nachvollziehn.

Gruss und gutes Wochenende

Avatar

Beitrag löschen

by Micha ⌂, Saturday, July 20, 2019, 08:47 (28 days ago) @ candleman

Hi,

das hat vorher immer alles geklappt? Wir haben das CSRF token kürzlich auch zur Löschfunktion hinzugefügt. Ich hätte jetzt vermutet, dass u.U. das Template nicht nachgezogen wurde aber da es nun einmal geklappt hat, bin ich etwas verwundert. Sehen die Querystrings der Links zum Löschen eines Beitrags so aus bei Dir in der Art?

...&delete_posting=0815&csrf_token=5d32d3ca2ee801.75561453&back=index

Viele Grüße
Micha

--
applied-geodesy.org - OpenSource Least-Squares Adjustment Software for Geodetic Sciences

Beitrag löschen

by candleman ⌂, Saturday, July 20, 2019, 11:19 (28 days ago) @ Micha

Hi,

das hat vorher immer alles geklappt? Wir haben das CSRF token kürzlich auch zur Löschfunktion hinzugefügt. Ich hätte jetzt vermutet, dass u.U. das Template nicht nachgezogen wurde aber da es nun einmal geklappt hat, bin ich etwas verwundert. Sehen die Querystrings der Links zum Löschen eines Beitrags so aus bei Dir in der Art?

...&delete_posting=0815&csrf_token=5d32d3ca2ee801.75561453&back=index

Viele Grüße
Micha

hmm, ähhhh, bei mir gibts keinen csrf_token

wwenn ich im Beitrag löschen will erscheint:

...forum/index.php?mode=posting&delete_posting=53705&back=entry

und wenn ich aus der indexansicht löschen will erscheint:

...forum/index.php?mode=posting&delete_posting=53705&back=index

wenn ich markiere erscheint:

.../forum/index.php?mode=posting&mark=53705


und dann

...forum/index.php?mode=posting&delete_marked=true

muss ich mir erst nen Token kaufen ???:-D

Avatar

Beitrag löschen

by Micha ⌂, Saturday, July 20, 2019, 11:46 (28 days ago) @ candleman

Hi,

dann stimmt was nicht mit Deiner Version. Laut Beschreibung haben wir dies in 2.4.20 hinzugefügt - siehe letzten Spiegelstrich. Nutzt Du ein eigenes Template?

/Micha

--
applied-geodesy.org - OpenSource Least-Squares Adjustment Software for Geodetic Sciences

Beitrag löschen

by candleman ⌂, Saturday, July 20, 2019, 12:07 (28 days ago) @ Micha

Hi,

dann stimmt was nicht mit Deiner Version. Laut Beschreibung haben wir dies in 2.4.20 hinzugefügt - siehe letzten Spiegelstrich. Nutzt Du ein eigenes Template?

/Micha

... ich hab nur in ...forum/themes/default/subtemplates

die posting.inc.tpl geändert, email notification entfernt
das mach ich aber schon seit Februar 2018 (wenn ich das beim update nicht vergess)

mein Hoster hat da ein Problem mit den mails über die Mailfunktion, er will smtp

Avatar

Beitrag löschen

by Micha ⌂, Saturday, July 20, 2019, 12:15 (28 days ago) @ candleman

Hi,

die posting.inc.tpl geändert, email notification entfernt

Du siehst ja die Liste an Files, die geändert wurden und Du siehst die Änderungen. Kannst Du diese mal bei Deiner Installation prüfen. Sind alle Änderungen bei Dir vorhanden?

mein Hoster hat da ein Problem mit den mails über die Mailfunktion, er will smtp

Ist eingebaut und Du wirst es mit der nächsten Version testen können.


/Micha

--
applied-geodesy.org - OpenSource Least-Squares Adjustment Software for Geodetic Sciences

Beitrag löschen

by candleman ⌂, Saturday, July 20, 2019, 12:53 (28 days ago) @ Micha

> Hi,

die posting.inc.tpl geändert, email notification entfernt


Du siehst ja die Liste an [link=]Files[/link], die geändert wurden und Du siehst die Änderungen. Kannst Du diese mal bei Deiner Installation prüfen. Sind alle Änderungen bei Dir vorhanden?

in der includes/posting.inc.php steht bei mir in Zeile 1455:
$smarty->assign('name', htmlspecialchars($field['name']));

in der themes/default/subtemplates/entry.inc.tpl steht in Zeile 53:
{if $options.delete}<li><a href="index.php?mode=posting&amp;delete_posting={$id}&amp;back=entry" class="delete" title="{#delete_message_linktitle#}">{#delete_message_linkname#}</a></li>{/if}

in der themes/default/subtemplates/thread.inc.tpl ist in Zeile 71 auch nix vom Token

themes/default/subtemplates/thread_linear.inc.tpl Zeile 71 auch ohne Token (datei auf dem server vom 01.04.2017)

im download von 2.4.20 seh ich die Token drinstehn.
ich meinte ich hätte die Updatelisten jeweils anständig abgearbeitet ??
Hmm, da werd ich die alle von dir benanntenn nochmal hochladen, das erneut checken und mich dann nochmal melden.

mein Hoster hat da ein Problem mit den mails über die Mailfunktion, er will smtp


Ist [link= eingebaut[/link] und Du wirst es mit der nächsten Version testen können.

da freu ich mich, da klappt das wieder. Ein feature mehr für meine Foristen

Gruss un Dank
Uli

Avatar

Beitrag löschen

by Micha ⌂, Saturday, July 20, 2019, 13:08 (28 days ago) @ candleman

Hallo,

im download von 2.4.20 seh ich die Token drinstehn.
ich meinte ich hätte die Updatelisten jeweils anständig abgearbeitet ??

Die Updateliste für 2.4.20 sieht aber vollständig aus - wenn auch etwas durcheinander...

Hmm, da werd ich die alle von dir benanntenn nochmal hochladen, das erneut checken und mich dann nochmal melden.

Ja, das wäre super.

Viele Grüße
Micha

--
applied-geodesy.org - OpenSource Least-Squares Adjustment Software for Geodetic Sciences

Beitrag gelöscht !

by candleman ⌂, Saturday, July 20, 2019, 13:13 (28 days ago) @ Micha

Hmm, da werd ich die alle von dir benanntenn nochmal hochladen, das erneut checken und mich dann nochmal melden.

Ja, das wäre super.

Viele Grüße
Micha

Hi Micha,
jetzt passts.
danke für support ;-)

RSS Feed of thread
powered by my little forum