Avatar

User to User emails not being sent 2.4.19 (General)

by Magma @, Saturday, April 27, 2019, 15:52 (27 days ago)

If I send email from the admin email address through an email client or webmail the message gets to the dummy account but if I use the email contactable method to send a message to the dummy account it does not get received?

Would that be a problem with the script or the hosting company?

Avatar

User to User emails not being sent 2.4.19

by Micha ⌂, Saturday, April 27, 2019, 16:33 (27 days ago) @ Magma

Hello,

Would that be a problem with the script or the hosting company?

I cannot confirm this behavior in my forum.

/Micha

--
applied-geodesy.org - OpenSource Least-Squares Adjustment Software for Geodetic Sciences

Avatar

User to User emails not being sent 2.4.19

by Magma @, Sunday, April 28, 2019, 10:35 (26 days ago) @ Micha

Weird because as a guest I try sending an email to a test user account using the envelope icon and the email is just not being received.

If I send a message using the envelope icon to the admin as a guest or user it gets received straight away.

So in my case it looks like any messages other than to the admin using the envelope icon are not being sent or received?

Avatar

User to User emails not being sent 2.4.19

by Magma @, Sunday, April 28, 2019, 10:44 (26 days ago) @ Micha

I just made my email contactable on this forum then logged out and tried sending a message to myself and it was received just fine. So looks like a host problem.

Avatar

User to User emails not being sent 2.4.19

by Magma @, Tuesday, April 30, 2019, 10:26 (24 days ago) @ Micha

I tried explaining to my host but they don't seem to understand.

To explain it better to them can you tell me how this form is sent https://mylittleforum.net/forum/index.php?mode=contact&user_id=100799

does it use your main email address?


Like I said if I use the envelope to contact admin the message is delivered but if I use the envelope to contact any other user the message does not get delivered like it is being blocked.

Avatar

User to User emails not being sent 2.4.19

by Micha ⌂, Tuesday, April 30, 2019, 10:38 (24 days ago) @ Magma

Hi,

To explain it better to them can you tell me how this form is sent https://mylittleforum.net/forum/index.php?mode=contact&user_id=100799

The form should call the my_mail-function.

does it use your main email address?

The 'FROM' argument is defined by the defined mail of the forum. The 'Reply-to' part is set by the user mail.

/Micha

--
applied-geodesy.org - OpenSource Least-Squares Adjustment Software for Geodetic Sciences

Avatar

User to User emails not being sent 2.4.19

by Magma @, Tuesday, April 30, 2019, 14:15 (24 days ago) @ Micha

What would be your best guess as to why this would stop working? would it be the host blocking it as spam from being sent.

I've tried explaining the problem a few times but they just say there is no issue with my email.

Avatar

User to User emails not being sent 2.4.19

by Micha ⌂, Wednesday, May 01, 2019, 07:29 (23 days ago) @ Magma

Hi,

we develop the forum using PHP and SQL language. Thus, official functions that are provided by these languages are used. The mail function is one of the official function. We only have access to the so-called return value. In case of the mail function, the return value is true or false, which means:

"Returns TRUE if the mail was successfully accepted for delivery, FALSE otherwise.

It is important to note that just because the mail was accepted for delivery, it does NOT mean the mail will actually reach the intended destination."

Please note the second paragraph!

To validate your behaviour, I would create a simple (stand-alone) php script that sends an email using the parameter defined by the mlf-mail function. Having such a script, the mail function is independently of the forum software and, thus, can be validated.

/Micha

--
applied-geodesy.org - OpenSource Least-Squares Adjustment Software for Geodetic Sciences

Avatar

User to User emails not being sent 2.4.19

by Magma @, Wednesday, May 01, 2019, 13:50 (23 days ago) @ Micha

I'm not too technical to be able to do that.

I have since found out that the activation email for new registered users is not being sent out either. I told the host this and they replied

"Usually, this issue is caused due to the incorrect SMTP settings in the form configuration file. Before we confirm the issue and to investigate it further from our end, can you please give a try by updating the SMTP server settings in the configuration file"

I have no clue where this form config file is or how to update smtp server settings.

All I know is it has been working fine and I have not changed any settings in the script admin or the server cpanel but all of a sudden the emails stopped being sent.

Avatar

User to User emails not being sent 2.4.19

by Micha ⌂, Wednesday, May 01, 2019, 20:01 (23 days ago) @ Magma

Hi,

how to update smtp server settings.

MLF does not support SMTP. Currently, the mail function from the PHP api is used. There is no SMTP server settings in MLF.

/Micha

--
applied-geodesy.org - OpenSource Least-Squares Adjustment Software for Geodetic Sciences

Avatar

User to User emails not being sent 2.4.19

by Magma @, Saturday, May 04, 2019, 13:19 (20 days ago) @ Micha

Got it fixed. It was the host dropping it as spam again.

Have you any plans to integrate an inbox into the software where you can send and view all messages between users when logged in? instead of the message going to the user's email address.

Avatar

User to User emails not being sent 2.4.19

by Auge ⌂ @, Sunday, May 05, 2019, 10:52 (19 days ago) @ Magma

Hello

Got it fixed. It was the host dropping it as spam again.

Once again …

Have you any plans to integrate an inbox into the software where you can send and view all messages between users when logged in? instead of the message going to the user's email address.

I thought about it a few times before. We got this wish from time to time years ago and it was mostly me who refused the wish. It was because this is My Little Forum and an inbox would add a further step of complexity to the code base. Additionally it would add an additional stage of responsibility for user data to the forum operator. This is something I want to prevent, where it's possible.

But with the upcoming reports of hosting providers who judge a few e-mails per day or hour, sended by the forum script over the normal way, as spam, I think I have to rethink my refusal. It seems to be more appropriate to make the forum operator responsible for those nonpublic messages (she/he is able to read at least with a tool like phpMyAdmin) than to deal with overcautious hosting providers who breaks single functions of the forum script.

Tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!

RSS Feed of thread
powered by my little forum