Version 2.4.17, posting not removable (General)

by Raving Richard, Tuesday, January 08, 2019, 03:14 (190 days ago)

Please report any problems with the new version here.

Dear MLF guys, since I update to this version I get a load of spam accounts registered, not a problem before updating but now a lot. More worryingly I also getting spam topics posted by guests that I cannot delete when logged in as Admin. I am set up to get a notify email of all new posts, for these spam posts that I cannot delete I get no notify email. Hope you can help my forum is getting overrun and I cannot delete these spam posts.

Tags:
bug, 2.4.17

Avatar

Version 2.4.17, posting not removable

by Auge ⌂ @, Tuesday, January 08, 2019, 08:46 (190 days ago) @ Raving Richard

Hello

Please report any problems with the new version here.


Dear MLF guys, since I update to this version …

A first question, from which version did you come from?

… I get a load of spam accounts registered, not a problem before updating but now a lot.

I observe here in this forum in the last three or four weeks a wave of never activated registrations. It's an amount of approximately 40 to 60 registrations per day that are marked in red in the user administration of the admin panel and are automatically deleted after 24 hours, when the time to activate an account is over.

And now, as I wanted to show you, how the user administration looks with pages of non-activated accounts, there is only a single one.

[image]

If you can see such accounts, not activated, because of that marked in red, and not older than 24 hours, don't worry. They get deleted after 24 hours and they don't count anywhere into the number of accounts.

We had no rework of any spam-detection relevant code in a release since 2.4.10 when we updated a few libraries, including Bad Behavior.

More worryingly I also getting spam topics posted by guests that I cannot delete when logged in as Admin.

I tested this just now and was able to post as a visitor and to delete the postings as an administrator from the main view. With which of the delete-posting-functions you tried to delete these postings (With the cross-icon in the main view, the mark-posting icon in combination with the delete-marked-postings link in the sidebar or from within the posting?)

I am set up to get a notify email of all new posts, for these spam posts that I cannot delete I get no notify email.

That sounds interesting. I've no clue what's gong on at the moment, I will ask you a few questions later.

Tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!

Version 2.4.17, posting not removable

by Raving Richard, Tuesday, January 08, 2019, 14:35 (190 days ago) @ Auge

Dear MLF Guys, I go from version 2.4.6 to 2.4.17
I try deleting spam posts using all methods, clicking the x near the topic, clicking delete in open thread, using red dot and clicking delete under sidebar. The page reloads but the posts are still there. I can do nothing to delete this guest spam posts.

Version 2.4.17, posting not removable

by Raving Richard, Tuesday, January 08, 2019, 16:51 (189 days ago) @ Auge

Dear MLF,
4 spam topics,

[image]

when click on topic it go to

[image]

with original topic having blank title and no way to delete. If I click on original title (-) it go back to the homepage.


normal user and guest posts do not do this only spammer posts

Avatar

Version 2.4.17, posting not removable

by Auge ⌂ @, Tuesday, January 08, 2019, 17:05 (189 days ago) @ Raving Richard

Hello

Thank you for the screenshots.

[image]

when click on topic it go to

[image]

Yes, I've also seen this only one time a few days ago. [edit]This was definitely before Micha upgraded this forum to version 2.4.17.[/edit]

with original topic having blank title and no way to delete. If I click on original title (-) it go back to the homepage.

I was able to delete the thread after realising, that there is an empty mother posting. But I'm not sure, if I remember the right way. Either I deleted it by clicking the red cross or by marking it and using the admin menu in the side bar.

Can you please create a database backup of the entries with only one of these spam threads (maybe the one from the screenshot)? I deleted "my" thread without investigation the structure and the how-to-do-it.

Tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!

Avatar

Version 2.4.17, posting not removable

by Micha ⌂, Wednesday, January 09, 2019, 08:02 (189 days ago) @ Auge

Hello,

Yes, I've also seen this only one time a few days ago. [edit]This was definitely before Micha upgraded this forum to version 2.4.17.[/edit]

In my forum, I saw this behavior one times months ago. It was a single posting (the thread opener). I took a look to the database and realised a missing thread id (was set to zero). The posting/thread was not flagged as spam and it was a real-life user!
I wasn't able to reproduce the error.

/Micha

--
applied-geodesy.org - OpenSource Least-Squares Adjustment Software for Geodetic Sciences

Avatar

Version 2.4.17, posting not removable

by Auge ⌂ @, Wednesday, January 09, 2019, 08:21 (189 days ago) @ Micha

Hello

Yes, I've also seen this only one time a few days ago. [edit]This was definitely before Micha upgraded this forum to version 2.4.17.[/edit]


In my forum, I saw this behavior one times months ago. It was a single posting (the thread opener). I took a look to the database and realised a missing thread id (was set to zero). The posting/thread was not flagged as spam and it was a real-life user!
I wasn't able to reproduce the error.

Mist!

Other question: Do you have any clue, what can cause the problem with the contact form, that some users of Magmas forum encounter, if it is not a forgotten script upgrade?

Tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!

Avatar

Version 2.4.17, posting not removable

by Micha ⌂, Wednesday, January 09, 2019, 08:33 (189 days ago) @ Auge

Hello,

Other question: Do you have any clue, what can cause the problem with the contact form, that some users of Magmas forum encounter, if it is not a forgotten script upgrade?

No, but I changed the condition (added the timespan condition). Thus, I will take a look to this issue today!

/Micha

--
applied-geodesy.org - OpenSource Least-Squares Adjustment Software for Geodetic Sciences

Avatar

Version 2.4.17, posting not removable

by Auge ⌂ @, Wednesday, January 09, 2019, 08:52 (189 days ago) @ Micha

Hello

Other question: Do you have any clue, what can cause the problem with the contact form, that some users of Magmas forum encounter, if it is not a forgotten script upgrade?


No, but I changed the condition (added the timespan condition). Thus, I will take a look to this issue today!

Thank you.

Tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!

Avatar

Release of version 2.4.17 phantom posting

by Magma @, Friday, January 11, 2019, 15:14 (187 days ago) @ Auge

Hello

Thank you for the screenshots.

[image]

when click on topic it go to

[image]


Yes, I've also seen this only one time a few days ago. [edit]This was definitely before Micha upgraded this forum to version 2.4.17.[/edit]

with original topic having blank title and no way to delete. If I click on original title (-) it go back to the homepage.


I was able to delete the thread after realising, that there is an empty mother posting. But I'm not sure, if I remember the right way. Either I deleted it by clicking the red cross or by marking it and using the admin menu in the side bar.

Can you please create a database backup of the entries with only one of these spam threads (maybe the one from the screenshot)? I deleted "my" thread without investigation the structure and the how-to-do-it.

Tschö, Auge

For the first time since using MyLittleForum I too got this problem the other day a couple of times. I could not delete them at all.

I had to go into the database and delete them that way which will be a real pain if it continually happens :no:

Avatar

Hunting the phantom postings

by Auge ⌂ @, Friday, January 11, 2019, 15:29 (186 days ago) @ Magma

Hello

O.k. i want to hunt the phantoms.

I'm sure that we will not be able to realise the cause of the problem, if we doesn't have database entries as real live examples. It's a pity that Raving Richard did not respond since days because I hoped for his support. Maybe he will respond in the future but I want to solve the issue as soon as possible.

@Micha: If we see such a posting/thread we need it undeleted. If you see one, please put it into a admin/mod-only category, so we can see it but no one else.

@Magma: If one of these postings encounter in your forum and you go into the database to delete it, please make a backup of the posting per copy'n'paste or so and provide it to us per posting.

Until we have a solution, it's IMHO the best to release a new version with the fixes for the other problems.

Thank you, tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!

Avatar

Hunting the phantom postings

by Magma @, Friday, January 11, 2019, 15:49 (186 days ago) @ Auge

@Magma: If one of these postings encounter in your forum and you go into the database to delete it, please make a backup of the posting per copy'n'paste or so and provide it to us per posting.

I will do that the next time it happens.

Avatar

Hunting the phantom postings

by Micha ⌂, Friday, January 11, 2019, 17:05 (186 days ago) @ Auge

Hi,

@Micha: If we see such a posting/thread we need it undeleted. If you see one, please put it into a admin/mod-only category, so we can see it but no one else.

Yes!

Until we have a solution, it's IMHO the best to release a new version with the fixes for the other problems.

Good idea.

/Micha

--
applied-geodesy.org - OpenSource Least-Squares Adjustment Software for Geodetic Sciences

Avatar

Hunting the phantom postings

by Micha ⌂, Friday, January 11, 2019, 17:20 (186 days ago) @ Auge

Hi,

@Micha: If we see such a posting/thread we need it undeleted. If you see one, please put it into a admin/mod-only category, so we can see it but no one else.

Now, we have an example.

I reproduce the reported bug which results in an db error as reported by Magma. Due to the error, the following SQL statements will not executed.

/Micha

--
applied-geodesy.org - OpenSource Least-Squares Adjustment Software for Geodetic Sciences

Avatar

Got it!

by Auge ⌂ @, Saturday, January 12, 2019, 15:18 (185 days ago) @ Micha

Hello

I reproduce the reported bug which results in an db error as reported by Magma. Due to the error, the following SQL statements will not executed.

I got it and will provide a fix.

Tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!

Avatar

Version 2.4.17, posting not removable

by Micha ⌂, Tuesday, January 08, 2019, 21:20 (189 days ago) @ Auge

Hello Auge,

And now, as I wanted to show you, how the user administration looks with pages of non-activated accounts, there is only a single one.

My fault. I test the new function but it was not perfect. If the admin enabled e.g. two uppercase letters, the regular expression matches a word like MYpassword but not MyPassword. I fixed this issue using lookahead (?=) expression.

/Micha

--
applied-geodesy.org - OpenSource Least-Squares Adjustment Software for Geodetic Sciences

Avatar

Bug solved with 2.4.18(.x), manual repair necessary

by Auge ⌂ @, Monday, January 14, 2019, 12:15 (184 days ago) @ Raving Richard

Hello

… I also getting spam topics posted by guests that I cannot delete when logged in as Admin. I am set up to get a notify email of all new posts, for these spam posts that I cannot delete I get no notify email. Hope you can help my forum is getting overrun and I cannot delete these spam posts.

With version 2.4.18 we solved the cause of the problem. But the existing problematic postings are not affected by the solution. Unfortunately you have to delete these postings by hand with phpMyAdmin or a similar tool. You can detect the affected postings because they have a value for the field id but wether a real value for tid nor for pid. Both fields have a value of 0 although the field tid should have the same value as it id has.

As an example for the broken status a fictive posting with id = 129:

  id | pid | tid | …
 129 |   0 |   0 | …

With the corrected tid (same value as id) …

  id | pid | tid | …
 129 |   0 | 129 | …

… you would be able to delete the posting with any forum function.

Anyway, if you find the postings from the time before updating to 2.4.18, delete it inside phpMyAdmin.

Tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!

Avatar

Bug solved with 2.4.18(.x), manual repair necessary

by Micha ⌂, Monday, January 14, 2019, 12:28 (184 days ago) @ Auge

Hello Auge,

FYI: I was able to delete my "example posting" here in this forum without using PHPMyAdmin. I used the x in the tree below the posting.

/Micha

--
applied-geodesy.org - OpenSource Least-Squares Adjustment Software for Geodetic Sciences

Avatar

Bug solved with 2.4.18(.x), manual repair necessary

by Auge ⌂ @, Monday, January 14, 2019, 13:57 (184 days ago) @ Micha

Hello

FYI: I was able to delete my "example posting" here in this forum without using PHPMyAdmin. I used the x in the tree below the posting.

I knew it was possible. I deleted a broken spam posting here in the forum around one or two weeks ago but I didn't know the way to go.

Tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!

RSS Feed of thread
powered by my little forum