Avatar

"Fold threads" not staying folded (Bugs)

by Magma, Saturday, March 10, 2018, 00:01 (75 days ago)

Something I noticed in 2.4.8 and this site when using IE not checked chrome, in table view or thread view, clicking "fold threads" then refreshing the page changes back to expanded threads. Not sure if it's just me.

So basically going to the homepage here and clicking "Fold threads" then refreshing the page, threads do not stay folded?

"Fold threads" not staying folded

by candleman ⌂, Saturday, March 10, 2018, 13:15 (74 days ago) @ Magma

Something I noticed in 2.4.8 and this site when using IE not checked chrome, in table view or thread view, clicking "fold threads" then refreshing the page changes back to expanded threads. Not sure if it's just me.

Das kenne ich aus Version 2.4.7 ,bei mir grad //noch// aktuell


So basically going to the homepage here and clicking "Fold threads" then refreshing the page, threads do not stay folded?

Avatar

"Fold threads" not staying folded

by Milo ⌂, Saturday, March 10, 2018, 20:35 (74 days ago) @ Magma

Hi,

So basically going to the homepage here and clicking "Fold threads" then refreshing the page, threads do not stay folded?

Yes, that's right. The reason is the JavaScript function. This makes folding very fast. To store the state, an ajax request is send to php function. The argument is the variable expand of type BOOLEAN, i.e. true or false. Due to #293, in main.inc.php, the state is checked for INTEGER values, i.e. 0 and 1.

One solution is to change the Query argument in JS to:

new Query("fold_threads", expand ? "0" : "1"),

Quote sign seem to be necessary because values like false or 0 (zero) are not transmitted (not shown in developer inspector)?!

I upload the modified JavaScript files. You can just replace the files to check this issue.

/Micha

--
applied-geodesy.org - OpenSource Least-Squares Adjustment Software for Geodetic Sciences

Tags:
bug, folding, ajax, javascript, type conflict, 2.4.8

Avatar

"Fold threads" not staying folded

by Magma, Saturday, March 10, 2018, 21:57 (74 days ago) @ Milo

I upload the modified JavaScript files. You can just replace the files to check this issue.

I changed the files and it seems to be working fine now with IE, Opera, Chrome.

Thank you guys

RSS Feed of thread
powered by my little forum