Avatar

'Open in thread' does not always lock on to the post (General)

by Magma, Wednesday, February 28, 2018, 11:57 (174 days ago)

Normally when you click 'open in thread' it locks to that post within the fully opened thread.

Just something I've noticed since going to 2.4.8 and ssl

If you have quite a big thread with many Images it will lock to that post for a split second but as more Images load above and below that post it moves off that post without you touching the scroll wheel leading you to lose where in the thread that post was. It doesn't lock and stay locked to that post while things load in.

Noticed it in IE and wifi, slower connections.

Avatar

It does but it jumps afterwards

by Auge ⌂ @, Wednesday, February 28, 2018, 12:28 (174 days ago) @ Magma

Hello

Normally when you click 'open in thread' it locks to that post within the fully opened thread.

Just something I've noticed since going to 2.4.8 and ssl

As far as I know, we haven't changed anything that affects the thread displaying.

If you have quite a big thread with many Images it will lock to that post for a split second but as more Images load above and below that post it moves off that post without you touching the scroll wheel leading you to lose where in the thread that post was. It doesn't lock and stay locked to that post while things load in.

That's a normal behaviour in every browser with or without SSL in the case, that the sizes of the images are unknown during the load process.

If the image size is known (by providing width and height by attributes) the browser allocates the necessary area for the image. Otherwise the browser takes only the space to display a small placeholder and the content of the alt-attribute (normally with a height of a line of text) until the image is loaded. That makes the content stot when image for image gets loaded and takes it's space.

Checking the following posting I can see, that we do not provide the width and height attributes. See therefore this detail from the source code of the checked posting (the section with the two avatar placeholders).

<p>32x32 pixels:<br />
<img src="images/uploaded/201802120934355a815fab3ed85.png" alt="[image]" /></p>
<p>128x128 pixels:<br />
<img src="images/uploaded/201802120934505a815fbad04d4.png" alt="[image]" /></p>

Opened issue #356 for it.

Tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!

Avatar

'Open in thread' does not always lock on to the post

by Auge ⌂ @, Thursday, March 01, 2018, 09:02 (173 days ago) @ Magma

Hello

After creating the Github issue #356 Milo and I had a short discussion about reading the sizes of the images and when this is possible and when not. We came to the following conclusion.

It's technically impossible to determine the size of an image until load process is finished, when the image gets loaded from an external source. This is, what a browser does and we can not improve anything in that case. Reading your threads i.e. about loading images via unencrypted connections into a page, that itself was loaded over an encrypted connection, we assume that your forum loads a bunch of external images.

The displaying of entries and threads with these images will not benefit from a function that determines the size of an image, uploaded to and locally stored at the forum server.

Tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!

Avatar

'Open in thread' does not always lock on to the post

by Magma, Thursday, March 08, 2018, 05:06 (166 days ago) @ Auge

Just to clarify this is for threads where Images have been uploaded not external. Most users upload Images on my forum and either use the thumbnail bbcode or not (which is why I keep bugging you guys for multi Image upload ;-))

RSS Feed of thread
powered by my little forum