Avatar

Admin delete user avatar missing? (General)

by Magma @, Wednesday, February 21, 2018, 19:54 (510 days ago)

I had this problem with 2.4.3 and just updated to 2.4.8 and still have the problem.

As admin I changed the avatar size for users to a smaller size. From that point on I no longer see the option to tick the box to delete a user's avatar for users with the new smaller size.

Even new users, If I go to edit their profile in the user administration their avatar does not show and the delete box does not show

If I go to (edit user) for a user that still has the larger size avatar, the avatar and delete box shows as normal and I can delete their avatar

Is this how it's meant to work? I thought you could always delete any user's avatar from the edit user page?

Tags:
bug

Avatar

Admin delete user avatar missing?

by Auge ⌂ @, Thursday, February 22, 2018, 10:02 (510 days ago) @ Magma

hello

I had this problem with 2.4.3 and just updated to 2.4.8 and still have the problem.

You not only had that problem, you caused it with a bug report. The problem is the consequence of a not complete implementation of the random part of the avatar file names. In the user edit form in the admin area the file name of the avatar without the random part (old behavior). Thatswhy you find the old avatars ([userid].jpg|png|gif) but not the avatars, which was uploaded with the new name system.

Even new users, If I go to edit their profile in the user administration their avatar does not show and the delete box does not show

Because the code searches the avatars under a wrong name, it couldn't find them and will not show the row with the avatar.

Is this how it's meant to work?

No, it isn't.

I thought you could always delete any user's avatar from the edit user page?

That's how it should work.

Tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!

Tags:
bug

Avatar

Admin delete user avatar missing?

by Magma @, Thursday, February 22, 2018, 12:30 (510 days ago) @ Auge

You not only had that problem, you caused it with a bug report.

Well that fix has worked fine since, did nobody coding think how the change would affect the administration side for the avatars? Don't shoot the messenger :-P :lol2:

Avatar

Admin delete user avatar missing?

by Auge ⌂ @, Thursday, February 22, 2018, 12:53 (510 days ago) @ Magma

You not only had that problem, you caused it with a bug report.


… did nobody coding think how the change would affect the administration side for the avatars?

Obviously not. We are humans, we make mistakes and additionally it seems not to be very common to change the users settings as an administrator. Otherwise someone else would have took notice in the past.

Don't shoot the messenger :-P :lol2:

No. :-)

Tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!

Avatar

Missing the label for the row delete user avatar

by Auge ⌂ @, Thursday, February 22, 2018, 20:05 (509 days ago) @ Magma

Hello

Found another issue. The Text item for the label of the avatars row in the user edit form does not exist. It's the key edit_user_avatar but I found it only in the norwegian language file, where it is a comment.

Tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!

Tags:
bug

Avatar

Bugs are fixed in the repository, but no new version

by Auge ⌂ @, Thursday, February 22, 2018, 20:46 (509 days ago) @ Magma

Hello

I meanwhile fixed this and the second bug in the master (for 2.5) and the legacy (2.4.x) branch. I'm not sure if it's enough for a new release. You can pick the necessary changes from these two commits in the case of an urgency.

Tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!

Tags:
bug

Avatar

Bugs are fixed in the repository, but no new version

by Micha ⌂, Thursday, February 22, 2018, 21:46 (509 days ago) @ Auge

Hi,

I'm not sure if it's enough

No, it wasn't enough. I expand the changes, see #353. I use the same syntax as in user.inc.php.

/Micha

--
applied-geodesy.org - OpenSource Least-Squares Adjustment Software for Geodetic Sciences

Avatar

Bugs are fixed in the repository, but no new version

by Magma @, Friday, February 23, 2018, 22:21 (508 days ago) @ Auge

Thanks, I changed the two commits, the avatar and delete box now show in admin but ticking the box and clicking ok-save does not delete the avatar?

Avatar

Bugs are fixed in the repository, but no new version

by Auge ⌂ @, Sunday, February 25, 2018, 14:29 (507 days ago) @ Magma

Hello and herrje!

Thanks, I changed the two commits, the avatar and delete box now show in admin but ticking the box and clicking ok-save does not delete the avatar?

I will have a look into the issue.

Tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!

Avatar

Bugs are fixed in the repository, but no new version

by Micha ⌂, Sunday, February 25, 2018, 18:33 (506 days ago) @ Magma

Thanks, I changed the two commits, the avatar and delete box now show in admin but ticking the box and clicking ok-save does not delete the avatar?

Really? Do you change the admin.inc.php like this commit? I checked it on my own forum and it should work as expected.

--
applied-geodesy.org - OpenSource Least-Squares Adjustment Software for Geodetic Sciences

Avatar

Bugs are fixed in the repository, but no new version

by Auge ⌂ @, Monday, February 26, 2018, 08:57 (506 days ago) @ Micha

Hello

Really? Do you change the admin.inc.php like this commit?

Magma said, he applied "the two commits". What I assume is, that these are my two commits, including the incomplete bugfix in admin.inc.tpl.

Tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!

Avatar

Bugs are fixed in the repository, but no new version

by Micha ⌂, Monday, February 26, 2018, 10:58 (506 days ago) @ Auge

Hi,

Magma said, he applied "the two commits"

Okay, I read: yours an my one. ;-)

/Micha

--
applied-geodesy.org - OpenSource Least-Squares Adjustment Software for Geodetic Sciences

Avatar

Bugs are fixed in the repository, but no new version

by Auge ⌂ @, Monday, February 26, 2018, 12:21 (506 days ago) @ Micha

Hello

Magma said, he applied "the two commits"


Okay, I read: yours an my one. ;-)

It was my incomplete fix and the fix for the missed label text (it's not the HTML-label but the label for the avatar-row). [edit]At least this is what I assume.[/edit]

Tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!

RSS Feed of thread
powered by my little forum