Avatar

the latest and oldest PHP versions for MLF (General)

by Auge ⌂, Tuesday, January 03, 2023, 11:19 (26 days ago) @ Solis

Hello Solis

What are the latest and oldest PHP versions for My Little Forum?

As stated in the section System requirements in the readme file PHP is required at least in version 7.3 and MySQL in version 5.5.3 or newer for the MLF 2.5-branch (version 20220508.1 or newer). We have tested the forum script up to PHP-version 8.0.x but not with PHP 8.1.x. This doesn't necessarily mean, that it will not run under PHP 8.1 but we can't assure you of that (because: untested).

I want to upgrade the My Little Forum to new version, but I'm afraid that the new PHP won't support My Little Forum.

Generally you should be safe with PHP in version 8.0.x. But (and that's a great "but"): We got reports about problems with upgrades to the latest version that was caused by our bad handling of a few of the prerequisites. If you have accounts that reused e-mail-addresses (two or more users that share the same e-mail-address, i.e. you self for testing purposes), the upgrade will fail and will leave the forum in an unusable state. Additionally you may run into a problem with the database table column size of the users e-mail-addresses. The occurence of this error depends on the database server configuration and so it's possible not to encounter this error.

Please be aware of these pitfalls. You can try to upgrade a complete copy of your forum (including copied and renamed database tables and a completely separate installation (with also separated config files)). When this upgrade succedes, you can either copy the changed installation back to your main forum and link to the new database connection and tables (in config/db_config.php) or you can repeat the upgrade with your main forum.

Nevertheless, my recommendation is to wait for completion of the upgrade-code rewrite, which I am currently working on.

Tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!


Complete thread:

 RSS Feed of thread