Avatar

Update des Forums (German / Deutsch)

by Micha ⌂, Saturday, July 20, 2019, 12:10 (92 days ago) @ Micha

Hallo,

ich habe heute ein weiteres Forum auf die pre-2.5 versucht zu updaten. Im Prinzip mit dem selben Ergebnis. Das Update wird mit der genannten SQL-Fehlermeldung abgebrochen. Diese habe ich, wie schon gezeigt, entsprechend behoben. Das hat also erneut funktioniert.

Dennoch habe ich ein weiteres Problem mit dem Updatescript gefunden, dass mich vor ein paar Tagen mutmaßen lies, es läge an den Files update_2.3.5-2.4.php und update_2.4.19.1-2.5.php. Das Problem ist, dass zwar geprüft wird, ob die Datei /config/db_settings.phpvorhanden und beschreibbar ist aber es kein else-Zweig gibt. Wenn also diese Datei dort nicht liegt oder man keine Schreibrechte hat, dann wird der ganze Rest zwar aktualisiert aber Teile fehlen schlicht, weil diese übersprungen wurden.

Ich habe ein else-Zweig mal ergänzt, sodass das Script dort abbrechen würde. Zur Info: Meine configs liegen außerhalb von htdocs.

/Micha

--
applied-geodesy.org - OpenSource Least-Squares Adjustment Software for Geodetic Sciences


Complete thread:

 RSS Feed of thread

powered by my little forum