Avatar

admin edit not possible? (Bugs)

by Auge ⌂ @, Saturday, June 01, 2019, 16:49 (80 days ago) @ Nico Hoffmann

Hello

i have some "sticky" threads, …. Now, one thread has become irrelevant for being always on the top, and i tried to remove the sticy-feature by login as admin and unchecking the checkbox.

After klicking OK I got the message "Der Eintrag kann nicht bearbeitet werden! Entweder es besteht keine Berechtigung, der Bearbeitungszeitraum ist abgelaufen, der Thread ist gesperrt oder der Eintrag hat bereits Antworten."

I tried to reproduce the reported bug but I can't. I am able to unstick and stick threads here in this forum and also in my own forum (both running version 2.4.20).

Indeed, the thread is rather old and has follow ups. But this should not prevent edits by admin?

No it shouldn't. The message is caused by a check for the user type and will also appear if you only want to edit the text of the posting. In the line #1255 of the posting.inc.php the script calls the function to check the authorisation to edit. The function get_edit_authorization itself checks the user type beginning with line 1688 and checks for an admin or mod in line #1690. Administrators and moderators are able to edit an entry at every time. In every other case the time and the reply restriction take effect.

    if($_SESSION[$settings['session_prefix'].'user_type'] > 0) // admin or mod
     {
      $authorization['edit'] = true;
      $authorization['delete'] = true;
     }

So my question is, why you get not detected as an administrator (or moderator).

P.S.: the thread was started before update from 2.3.5 to 2.4.20.

I am not aware of any change, related to the stick-thread-feature, that could cause this problem.

Tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!


Complete thread:

 RSS Feed of thread

powered by my little forum