Avatar

Bug in version 2.4.15 (Bugs)

by Auge ⌂ @, Friday, December 07, 2018, 11:52 (221 days ago) @ Rövarn

Hallo

I have trouble updating to 2.4.15, i had 2.3.4 updated to 2.3.5 finally to 2.4.15.
Now it's not possible to edit posts, backup does not work.

This soulds like the bug in Version 2.4.14. With the upload of admin.inc.php, functions.inc.php and posting.inc.php from the 2.4.15-package like mentioned in the update script this should be solved. But …

I have tried to do a new installation of 2.4.15, I get the same error...

… that sentence left me with doubts.

I have the prefix mlf05_ in the db

And yes, I found two occurences of hardcoded table names with the prefix mlf2_ in posting.inc.php, lines 1243 and 1245. There's only one word in the world for this: Fuck! My forum uses the table prefix mlf2_ so the bug did not occure during the tests.

With replacing FROM mlf2_subscriptions WHERE with FROM " . $db_settings['subscriptions_table'] . " WHERE you should be able to get the version 2.4.15 working. I'll release a new fixed version.

Tschö, Auge

--
Trenne niemals Müll, denn er hat nur eine Silbe!


Complete thread:

 RSS Feed of thread

powered by my little forum