Mailserver-Fehler version 2.4.3 (Bugs)

by Tommy Nilsson ⌂ @, Wednesday, July 18, 2018, 08:23 (216 days ago) @ Auge

Hello

After updating one of my forums from version 2.3.4 to version 2.4.3, the forum can´t send mails to users - they get:

registered_send_error = Das Benutzerkonto wurde eingerichtet aber der Aktivierungslink konnte nicht gesendet werden (Mailserver-Fehler). Bitte den Administrator kontaktieren um das Konto manuell zu aktivieren.


There was, as Milo stated, not a single bit changed in the related function my_mail between version 2.3.4 and 2.4.3. On the other hand I'm not sure, if there was changes in the code around the function calls in the several scripts (the function is in use when registering, when posting, when mailing from the contact form …).

But, said that, it is IMHo remarkable, that noone else reported any problems at that point.

It works fine in one of my other forums that still runs version 2.3.4.


Does the forum with version 2.3.4 run on the same server as the one with version 2.4.3 (the one with the broken mailing function)?

Did you perform the test of the mailing function outside the forum, as Milo proposed?

Tschö, Auge

Hi
My mistake - it doesn´t work in version 2.3.4 either (my test worked only because I used my own mailaddress).
BUT! I think I have figured out what is wrong. My host (One.com) has blocked the option to send emails with "from" mailaddresses that does not belong to the actual domain.

Snippet from php mail:

$headers = 'From: webmaster@example.com' . "\r\n" .
'Reply-To: webmaster@example.com' . "\r\n" .
'X-Mailer: PHP/' . phpversion();

I did a couple of tests on the domain Signalposten.dk:

This didn´t work:

$headers = 'From: webmaster@example.com' . "\r\n" .
'Reply-To: webmaster@example.com' . "\r\n" .
'X-Mailer: PHP/' . phpversion();

This DID work:

$headers = 'From: info@signalposten.dk' . "\r\n" .
'Reply-To: webmaster@example.com' . "\r\n" .
'X-Mailer: PHP/' . phpversion();

Looking in the function my_mail in functions.inc.php it looks like you put the users mailaddress in the "From" field and thats why it fails.

If I´m right, you should put the forum mailaddress in the "From" field and the users mailaddress in the "Reply-to" field. My test at Signalposten.dk worked using this approach.

What are your thoughts?

BTW: I´m not the only one with this problem. My colleague in Sweden has the exact same problem (also hosted on One.com):
http://www.jvmv2.se/forum/index.php?id=208286

/Tommy


Complete thread:

 RSS Feed of thread

powered by my little forum