Avatar

version 2.4.2, broken read status (General)

by Magma, Monday, March 13, 2017, 14:43 (102 days ago)
edited by Auge, Thursday, May 18, 2017, 13:57

Hi, Second problem I see.

Posts that have been read as a guest are not acting the same as a user. When I read a thread as a guest then click 'back to forum index' the title of the thread and replies is still bright blue and the icon still red as though it's still an un-read post?

Avatar

version 2.4.2, broken read status

by Auge ⌂ @, Monday, March 13, 2017, 15:35 (102 days ago) @ Magma
edited by Auge, Thursday, May 18, 2017, 13:57

Hello

Second problem I see.

Posts that have been read as a guest are not acting the same as a user. When I read a thread as a guest then click 'back to forum index' the title of the thread and replies is still bright blue

Are you reading the forum in the nested view or every entry on the single-posting-page?

and the icon still red as though it's still an un-read post?

That's normal and works that way since ages. The red arrow for "new" entries is shown, when the entry date is newer than the cookie value for the users last visit of the forum.

Tschö, Auge

--
further development of mlf1

Avatar

version 2.4.2, broken read status

by Magma, Monday, March 13, 2017, 15:48 (102 days ago) @ Auge
edited by Auge, Thursday, May 18, 2017, 13:57

Hello

Second problem I see.

Posts that have been read as a guest are not acting the same as a user. When I read a thread as a guest then click 'back to forum index' the title of the thread and replies is still bright blue


Are you reading the forum in the nested view or every entry on the single-posting-page?

Using threaded view, opened the complete thread. In 2.4.2 If I do the same as a user then click 'back to forum index' the thread title text and reply text is darker blue and the red icons no longer show which shows that you've read the posts. I thought this should be the same for a guest user too?


As a guest opening a complete thread then clicking 'back to forum index' the thread title text is still bright blue and the icon and reply icons are red still.

Avatar

version 2.4.2, broken read status

by Auge ⌂ @, Monday, March 13, 2017, 16:04 (102 days ago) @ Magma
edited by Auge, Thursday, May 18, 2017, 13:57

Hello

Second problem I see.

Posts that have been read as a guest are not acting the same as a user. When I read a thread as a guest then click 'back to forum index' the title of the thread and replies is still bright blue


Are you reading the forum in the nested view or every entry on the single-posting-page?


Using threaded view, opened the complete thread.

Ok.

In 2.4.2 If I do the same as a user then click 'back to forum index' the thread title text and reply text is darker blue and the red icons no longer show which shows that you've read the posts.

Yes, that's the plan.

I thought this should be the same for a guest user too?

No, not exactly that. New entries are marked with the red arrow over the cookie value for the last visit. Guests can only use the browser styles for visited links (not entries/postings). But with the threaded view a visitor do not follow every link to every entry. So all links except the one the visitor clicks are and stay unvisited.

As a guest opening a complete thread then clicking 'back to forum index' the thread title text is still bright blue and the icon and reply icons are red still.

Is the one link you clicked marked as visited?

Tschö, Auge

--
further development of mlf1

Avatar

version 2.4.2, broken read status

by Magma, Tuesday, March 14, 2017, 01:06 (101 days ago) @ Auge
edited by Auge, Thursday, May 18, 2017, 13:58

As a guest opening a complete thread then clicking 'back to forum index' the thread title text is still bright blue and the icon and reply icons are red still.


Is the one link you clicked marked as visited?

No, as a guest if I click on a new post (bright blue text, red icon) read the post then click 'Back to the forum index' the post title still shows as bright blue with red icon.

As a guest, just say I have a new original post and 4 replies, if I open the complete thread and then go back to the index the original and 4 replies are bright blue with red icon.

as a guest If I open just one reply and go back to the index the original post and 4 replies are still bright blue with red icon.


As a user if I open the complete thread and go back to the index the original post and 4 replies are dark blue text and no red icon

As a user if I open just one reply and go back to the index that one reply text is dark blue with no red icon and the other 3 replies and original post are still bright blue with a red icon


I really want the guest read posts to work like it does for registered users?

RSS Feed of thread
powered by my little forum