Update 2.3.3 to 2.3.5 failed (General)

by Christian @, Wednesday, August 31, 2016, 13:40 (445 days ago)

Dear community,
I just updated from V 2.3.3 to 2.3.5 as instructed (as interim step to upgrad to 2.3.6)
But after following the instructions and deleting "templates_c" i get the following error message:
"Access denied for user ''@'localhost' (using password: NO)"

I did not make any changes on user access permissions or directory permissions.
Was goes wrong?
Any ideas?

Thank you!
Bye,
Christian

Avatar

Update 2.3.3 to 2.3.5 failed

by Auge ⌂ @, Wednesday, August 31, 2016, 13:50 (445 days ago) @ Christian

Dear community,
I just updated from V 2.3.3 to 2.3.5 as instructed (as interim step to upgrad to 2.3.6)
But after following the instructions and deleting "templates_c" i get the following error message:
"Access denied for user ''@'localhost' (using password: NO)"

That's the error, if you open a connection to the database and an error occurs at that point.

I did not make any changes on user access permissions or directory permissions.
Was goes wrong?
Any ideas?

1. Please check the userdata for the database in the file config/db_settings.php.
2. Please check, if you transferred every actualised program file to the webspace.

Please report here.

Tschö, Auge

--
further development of mlf1

Update 2.3.3 to 2.3.5 failed

by Christian @, Wednesday, August 31, 2016, 14:30 (445 days ago) @ Auge

Dear community,
I just updated from V 2.3.3 to 2.3.5 as instructed (as interim step to upgrad to 2.3.6)
But after following the instructions and deleting "templates_c" i get the following error message:
"Access denied for user ''@'localhost' (using password: NO)"


That's the error, if you open a connection to the database and an error occurs at that point.

I did not make any changes on user access permissions or directory permissions.
Was goes wrong?
Any ideas?


1. Please check the userdata for the database in the file config/db_settings.php.

User and Password in config/db_settings.php are still correct.

2. Please check, if you transferred every actualised program file to the webspace.

I transferred according to the instructions the following files/directories:

/includes/posting.inc.php
/includes/functions.inc.php
/includes/admin.inc.php
/modules/smarty/


Please report here.

Tschö, Auge


Thank you for the fast reply!
Bye,
Christian

Update 2.3.3 to 2.3.5 failed

by Christian @, Friday, September 02, 2016, 14:44 (443 days ago) @ Christian

Dear community,
I just updated from V 2.3.3 to 2.3.5 as instructed (as interim step to upgrad to 2.3.6)
But after following the instructions and deleting "templates_c" i get the following error message:
"Access denied for user ''@'localhost' (using password: NO)"


That's the error, if you open a connection to the database and an error occurs at that point.

I did not make any changes on user access permissions or directory permissions.
Was goes wrong?
Any ideas?


1. Please check the userdata for the database in the file config/db_settings.php.


User and Password in config/db_settings.php are still correct.

2. Please check, if you transferred every actualised program file to the webspace.


I transferred according to the instructions the following files/directories:

/includes/posting.inc.php
/includes/functions.inc.php
/includes/admin.inc.php
/modules/smarty/


Please report here.

Tschö, Auge

Still does not work with the same error message. Any further ideas? Thanks in advance!

Bye Christian

Update 2.3.3 to 2.3.5 failed - solved

by Christian @, Saturday, September 03, 2016, 06:10 (443 days ago) @ Christian

Hello together,
Problem solved. No direct update from 2.3.3 to 2.3.5 possible. I made a rollback to 2.3.3, then updates to 2.3.4 and then via interim 2.3.5 finally to 2.3.6.1 and it worked. Seems to be a error in the file update list and the link to the source files in 2.3.5 package.
Bye Christian

Avatar

Update 2.3.3 to 2.3.5 failed - solved

by Auge ⌂ @, Sunday, September 04, 2016, 15:20 (441 days ago) @ Christian

Hello

Problem solved. No direct update from 2.3.3 to 2.3.5 possible.

I had the same idea when thinking about your problem.

I made a rollback to 2.3.3, then updates to 2.3.4 and then via interim 2.3.5 finally to 2.3.6.1 and it worked. Seems to be a error in the file update list and the link to the source files in 2.3.5 package.

The file list for the update process is handled in the same manner for every version change. It should be a problem for every update when one or a few versions are ommited. The list for the version 2.3.4, the version you ommited, shows a bunch of file names. I assume, you didn't saw this list, when you started your first attempt.

I would expect every update with a version gap to fail. On the other hand, I didn't saw a thread about such a problem in this forum.

Tschö, Auge

--
further development of mlf1

Avatar

Update 2.3.3 to 2.3.5 failed - finally solved

by Auge ⌂ @, Wednesday, October 05, 2016, 19:09 (410 days ago) @ Christian

Hello

Problem solved. No direct update from 2.3.3 to 2.3.5 possible. I made a rollback to 2.3.3, then updates to 2.3.4 and then via interim 2.3.5 finally to 2.3.6.1 and it worked. Seems to be a error in the file update list and the link to the source files in 2.3.5 package.

Milo, one of our team members, confirmed the bug you reported for every update with version gaps. He also submitted a fix. That said, this problem should be fixed from now on (new version 2.3.7 (at the moment in beta stage)) and an update should be possible from the lowest mentioned version (2.2) with a complete and detailed file and directory listing and from lower versions with a listing of all directories.

Tschö, Auge

--
further development of mlf1

RSS Feed of thread
powered by my little forum