Avatar

updating 2.3.4 --> 2.3.7 und php-Kompabilität (General)

by Auge ⌂ @, Wednesday, January 04, 2017, 13:38 (81 days ago) @ Ulrich Zeun
edited by Auge, Wednesday, February 22, 2017, 14:44

Hallo

[edit]Ahem. Meine hier immer wieder eingestreuten Fragen nach den Versionen kannst du ignorieren. Wenn ich auch mal den Betreff gelesen hätte, hätte ich sie nicht gestellt.[/edit]

leider werde ich nicht mit den anderen Forumseinträgen schlau genug oder bin auch nicht sicher, ob alles stimmt.

Hmm, dann woll'n wir mal.

Auch ich würde gerne die Version einmal updaten und sehe, wenn ich die ungezippten update/update.sql und update_2.x-2.3.php in das update vErzeichnis des Servers hochlade, den Link zu "update_2.x-2.3.php" - diese war aber auch schon vorher zu sehen

Diese Datei ist schon immer dabei und ihr Name wird mit jedem großen Programm-Update (durch die erste Ziffer hinter "2." kenntlich gemacht) auf die nun aktuelle Hauptversion angepasst. Bei kleinen Versionssprüngen für Bugfixes, z.B. von 2.3.4 auf 2.3.5 oder 2.3.7 ändert sich der Name der Updatedatei jedoch nicht. Werden die Updatedateien nach einem Update nicht vom Server gelöscht, siehst du sie auch, wenn du auf die Update-Seite der Administration gehst, auch wenn es dann tatsächlich kein verfügbares Update gibt.

(update auf 2.3.4 = das ist die aktuelle Version).

Die bei dir installierte Version ist also die 2.3.4.

Schon mal die frage hier, warum das File nicht update_2.x-2.3.7 php heißt.

Das sollte mit den obigen Ausführungen beantwortet worden sein.

ICh habe ein update versucht und es kam sofort die Fehlermeldung
"Database error in line 888"
In der Zeile steht aber auch nur "$update['errors'][] = 'Database error in line '.__LINE__.': ' . mysqli_error($connid);"

Der Fehler ist in der zuvor notierten Datenbankabfrage zu suchen. Das ist jene Abfrage, die die im Nachbarthread besprochenen Probleme löst (hier halt im Zuge deines Updateprozesses) und die Abfrage selbst funktioniert. Wichtig wäre nun, zu wissen, ob du direkt von deiner Version 2.3.4 auf eine Version nach 2.3.5 updaten wolltest. Steht denn nach "Database error in line 888" eine Fehlermeldung oder ist dies der ganze Text?

Ich vermute, dass du bisher nur die Dateien update/update.sql und update/update_2.x-2.3.php hochgeladen hast. Die MLF-Versionen ab 2.3.5 laufen aber mit anderen Zugriffsfunktionen für die Datenbank, die in deiner bisherigen Installation noch nicht vorhanden sind. Der Aufbau des Update-Skripts ist da leider nicht sehr konsequent.

Vermutlich hilft ein Schritt-für-Schritt-Update, aber dazu möchte ich erst wissen, ob meine obige Vermutung mit der nicht vorhandenen Fehlermeldung nach dem Text "Database error in line 888" stimmt.

Grundsätzlich beschäftige ich mcih auch gerrade mit dem update, da der Provider auch bei mir/uns die PHP Version von 5.5 auf eine höhere umstellen möchte und ansosnten eine Wartungsgebühr nimmt.
Daher auch noch mal die Frage, ob mylittleforum auch mit php 5.6 oder höher (mittlerweile) läuft.

Da mittlerweile 5.6 die niedrigste, noch mit Sicherheitsupdates versorgte PHP-Version ist, und darüber nur die 7-er Versionen kommen, ist ein Update des PHP-Interpreters seitens deines Hosters auf mindestens diese Version ein verantwortungsbewusster Schritt. Und ja, My Little Forum läuft mit PHP5.6 und ab der Version 2.3.5 auch mit PHP7.

Tschö, Auge

--
further development of mlf1


Complete thread:

 RSS Feed of thread

powered by my little forum