Avatar

Another Bug in 2.3.7? Avatars (General)

by Auge ⌂ @, Friday, November 25, 2016, 15:29 (359 days ago) @ Magma

Hello

So far I know, you degraded your installation from version 2.3.7 to 2.3.6.1.

I have not gone back to 2.3.6.1 yet. I'm still on 2.3.7 at the moment and when I upgraded I did delete the contents of templates_c directory apart from the .dummy file.

Aha, two days ago you told me, you've reverted to 2.3.6.1. Maybe I misinterpreted you.

Getting back to the avatar problem. Not being a web coder I'm not sure how it works but when a page refreshes doesn't the script grab the avatar image from the server via the url of the image?

Yes it does. The problem in this case is the fact, that the file name of the avatar is a compound of the user-ID and the file-ending. Milos ID is 25 and he uses a GIF, so the avatars file name is 25.gif. If your user replaces the old avatar with a new image of the same file type, the file name will be identical. The browser might use it's old, cached version instead the new one.

I don't understand how a page can load with the old avatar if the old avatar image is no longer in the images/avatars folder. How is that possible?

It's a question of the implementation of the browser, if he asks for a new version of the file, when he has a file with the same name from the same source in his cache. I would expect such problems especially, when the browser is in the private mode.

Tschö, Auge

--
further development of mlf1


Complete thread:

 RSS Feed of thread

powered by my little forum