Avatar

Update auf Version 2.4 mit Fehler (General)

by Auge ⌂ @, Thursday, March 30, 2017, 11:23 (113 days ago) @ willie
edited by Auge, Thursday, May 18, 2017, 14:01

Hallo

Attention: The update is only possible when the existing installation is a version 2.3.5 or higher!


hab (lt. System) die 'aktuelle Version: 2.3.7' am Laufen

und bekomme beim Updateversuch übers backend trotzdem folgende Meldung:

"Fehler!

Error in line 358: This update file doesn't work with the current version."

Jetzt steh ich da ich armer Tor . . .

Nun ja, das "richtige" Updateskript hat nicht mal eine Zeile 358. Das alte Skript, welches genau bis zur 2.3.7 funktioniert, schon. In der aktuellen Datei ist jedoch bei Zeile 299 Schluss. Die angezeigte Fehlermeldung ist im Übrigen korrekt, weil das Update auf die 2.4 mit dem alten Skript nicht funktioniert.

Ist das schon mal aufgetreten ?

Mag sein.

hat das wer gefixt ?

Muss ja nicht, wie oben schon angedeutet und unten detaillierter ausgeführt. ;-)

wo ist der Trick ?

Benutze bitte das richtige Updateskript (update_2.3.5-2.4.php). Lösche am besten das alte Updateskript vom Server, damit du nicht noch einmal das falsche Skript aufrufst. Achte bitte, bevor du in die nächste Falle rennst, darauf, vor dem Update auch die Datei config/VERSION der neuen Version auf den Server zu laden.

Tschö, Auge

--
further development of mlf1


Complete thread:

 RSS Feed of thread

powered by my little forum